From 9432bb2e32291095501dd4f413762f8236966c87 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Fri, 31 May 2024 18:08:21 +0200
Subject: dev-python/mapbox-vector-tile: Bump to 2.1.0
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/mapbox-vector-tile/Manifest             |  1 +
 .../mapbox-vector-tile-2.1.0.ebuild                | 37 ++++++++++++++++++++++
 2 files changed, 38 insertions(+)
 create mode 100644 dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild

(limited to 'dev-python/mapbox-vector-tile')

diff --git a/dev-python/mapbox-vector-tile/Manifest b/dev-python/mapbox-vector-tile/Manifest
index 03b05a5c321d..1ab1e042a681 100644
--- a/dev-python/mapbox-vector-tile/Manifest
+++ b/dev-python/mapbox-vector-tile/Manifest
@@ -1 +1,2 @@
 DIST mapbox-vector-tile-2.0.1.gh.tar.gz 229202 BLAKE2B 9afa12583f1f2697c8fd3a7ad540851c2b3ea7bca26bf7945aa52ad9c2486f4b6ec0a0bc84e750e18ecb55a51558659284d52efedcb724ec5de98f965d78b954 SHA512 67648c27792557a5e011732c31f8a0a3e6efca8630086e55e6fdc433953b820ef6405031d10692999026c604f3977eb00bafa9a1a7015f02c3dca87ca91eadf6
+DIST mapbox-vector-tile-2.1.0.gh.tar.gz 229585 BLAKE2B d4ed6034b8cea35b3bfe0db8ed3f9f094021654045dce560e36d9d21398c8cd41975848dd44de13c1e9f0a4c37d94835e349c9df7283b994fde60ff66eceda9d SHA512 d2ab9f0aba5150a4e9e0e7c9b29a3754f25ac9a1368e5c2909d773e1dc2197dcab59c047f68cdcf217727e0422bd8670ade797db74b26b95ce04f24564938c1d
diff --git a/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild
new file mode 100644
index 000000000000..17a2fcdba745
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mapbox Vector Tile encoding and decoding."
+HOMEPAGE="
+	https://github.com/tilezen/mapbox-vector-tile/
+	https://pypi.org/project/mapbox-vector-tile/
+"
+SRC_URI="https://github.com/tilezen/mapbox-vector-tile/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+	dev-python/protobuf-python[${PYTHON_USEDEP}]
+	>=dev-python/pyclipper-1.3.0[${PYTHON_USEDEP}]
+	>=dev-python/pyproj-3.4.1[${PYTHON_USEDEP}]
+	>=dev-python/shapely-2.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+	# don't install into top-level
+	sed -Ei '/include = \[/,/\]/ { /(README|CHANGELOG)/d }' pyproject.toml || die
+	# relax the dep
+	sed -i -e '/protobuf/s:\^[0-9.]*:*:' pyproject.toml || die
+	distutils-r1_src_prepare
+}
-- 
cgit v1.2.3-65-gdbad