From bb352342ccaffe47d02eb7f27ad41780ab3512a9 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Fri, 6 Oct 2023 20:59:20 +0200
Subject: dev-python/meson-python: Remove old
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/meson-python/Manifest                   |  1 -
 .../files/meson-python-0.13.2_Mach-O_bundle.patch  | 21 -------
 .../meson-python/meson-python-0.13.2-r1.ebuild     | 68 ----------------------
 3 files changed, 90 deletions(-)
 delete mode 100644 dev-python/meson-python/files/meson-python-0.13.2_Mach-O_bundle.patch
 delete mode 100644 dev-python/meson-python/meson-python-0.13.2-r1.ebuild

(limited to 'dev-python/meson-python')

diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index d8a34123b38f..33f179cd56d0 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,2 +1 @@
-DIST meson-python-0.13.2.gh.tar.gz 69575 BLAKE2B ddcab5530e7c235057752f1c355052120863167fc601b669e3add713079400cf95617be84989e06542125850559124d70a693a618cbec456c0e59e3f80d14c5f SHA512 b5518c5e9ccbec40747f2c08a83134f012557e0d9612b99999473d2ae7fdfdeae5b7552dc16cebb493133c3ed8c52153b3e3afd3cef32d0f3a65771ebbb5b3bb
 DIST meson-python-0.14.0.gh.tar.gz 72523 BLAKE2B d0fd66dee8a5efd73e617033aec3f14eb66affe72cd84c30a740820f5a0c34a4ae4ffd31e1df26312513b312940f62af436b9870216ee93d7543b4f02dec6637 SHA512 f40963a9c2bca8edf0f5651f9f4f1fab8df89cca715dd8dc0dec11ac53a591ee19d2d06edead917f15382410a51a37cd4efcee2c52696eb10a546b080bac2ad8
diff --git a/dev-python/meson-python/files/meson-python-0.13.2_Mach-O_bundle.patch b/dev-python/meson-python/files/meson-python-0.13.2_Mach-O_bundle.patch
deleted file mode 100644
index 2531c93f41e2..000000000000
--- a/dev-python/meson-python/files/meson-python-0.13.2_Mach-O_bundle.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Support .bundle python modules at Prefix/macOS.
-
-Not forwarding to upstream because we are reflecting on the naming
-scheme of plugin modules on Prefix/macOS.
-
-Bug: https://bugs.gentoo.org/910401
-Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-
-Index: meson-python-0.13.2/mesonpy/__init__.py
-===================================================================
---- meson-python-0.13.2.orig/mesonpy/__init__.py
-+++ meson-python-0.13.2/mesonpy/__init__.py
-@@ -129,7 +129,7 @@ _STYLES = _init_colors()  # holds the co
- 
- _SUFFIXES = importlib.machinery.all_suffixes()
- _EXTENSION_SUFFIXES = importlib.machinery.EXTENSION_SUFFIXES
--_EXTENSION_SUFFIX_REGEX = re.compile(r'^\.(?:(?P<abi>[^.]+)\.)?(?:so|pyd|dll)$')
-+_EXTENSION_SUFFIX_REGEX = re.compile(r'^\.(?:(?P<abi>[^.]+)\.)?(?:so|pyd|dll|bundle)$')
- assert all(re.match(_EXTENSION_SUFFIX_REGEX, x) for x in _EXTENSION_SUFFIXES)
- 
- 
diff --git a/dev-python/meson-python/meson-python-0.13.2-r1.ebuild b/dev-python/meson-python/meson-python-0.13.2-r1.ebuild
deleted file mode 100644
index a6abd080a7af..000000000000
--- a/dev-python/meson-python/meson-python-0.13.2-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Meson PEP 517 Python build backend"
-HOMEPAGE="
-	https://pypi.org/project/meson-python/
-	https://github.com/mesonbuild/meson-python/
-"
-SRC_URI="
-	https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
-		-> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
-	>=dev-python/pyproject-metadata-0.7.1[${PYTHON_USEDEP}]
-	>=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
-	!kernel_Darwin? ( dev-util/patchelf )
-	$(python_gen_cond_dep '
-		>=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
-	' 3.10)
-"
-BDEPEND="
-	>=dev-python/cython-0.29.34[${PYTHON_USEDEP}]
-	test? (
-		dev-python/pytest-mock[${PYTHON_USEDEP}]
-	)
-"
-
-PATCHES=( "${FILESDIR}"/meson-python-0.13.2_Mach-O_bundle.patch )
-
-distutils_enable_tests pytest
-
-python_test() {
-	local EPYTEST_DESELECT=(
-		# requires network access
-		tests/test_pep518.py::test_pep518
-		# requires git repo
-		# https://github.com/mesonbuild/meson-python/issues/397
-		tests/test_project.py::test_user_args
-	)
-	unset NINJA
-
-	if [[ ${EPYTHON} == pypy3 ]]; then
-		EPYTEST_DESELECT+=(
-			# broken venv usage that copies pypy3 executable, making it
-			# unable to find lib_pypy
-			tests/test_editable.py::test_editable_install
-			tests/test_editable.py::test_editble_reentrant
-			tests/test_examples.py::test_spam
-			tests/test_wheel.py::test_local_lib
-		)
-	fi
-
-	epytest
-
-	rm -rf docs/examples/spam/build/ || die # remove artifacts
-}
-- 
cgit v1.2.3-65-gdbad