From a1e4828e2ba563dbf0aa151d1a1451171e759b38 Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Wed, 5 Aug 2020 18:52:15 +0200
Subject: dev-ros/unique_id: fix tests

Closes: https://bugs.gentoo.org/734686
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
---
 dev-ros/unique_id/unique_id-9999.ebuild | 7 +++++++
 1 file changed, 7 insertions(+)

(limited to 'dev-ros/unique_id/unique_id-9999.ebuild')

diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
index 3614a9ea3228..32432dfa5632 100644
--- a/dev-ros/unique_id/unique_id-9999.ebuild
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -25,3 +25,10 @@ DEPEND="${RDEPEND}
 		dev-cpp/gtest
 		$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
 	)"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+	# Those tests fail and are commented as undefined behavior in the code
+	export GTEST_FILTER='-BoostUUID.fromUrnString:BoostUUID.fromTooLongString:BoostUUID2.fromUrnString:BoostUUID2.fromTooLongString'
+	ros-catkin_src_test
+}
-- 
cgit v1.2.3-65-gdbad