From 27abb828ec5f03a8dd5a1f19f8d77938647ce100 Mon Sep 17 00:00:00 2001
From: Manuel RĂ¼ger <mrueg@gentoo.org>
Date: Sun, 22 Jan 2017 02:51:32 +0100
Subject: sys-boot/os-prober: Version bump to 1.73

Package-Manager: portage-2.3.3
---
 sys-boot/os-prober/Manifest              |  1 +
 sys-boot/os-prober/os-prober-1.73.ebuild | 75 ++++++++++++++++++++++++++++++++
 2 files changed, 76 insertions(+)
 create mode 100644 sys-boot/os-prober/os-prober-1.73.ebuild

(limited to 'sys-boot/os-prober')

diff --git a/sys-boot/os-prober/Manifest b/sys-boot/os-prober/Manifest
index 92c12aac8abc..288d5e42ceb9 100644
--- a/sys-boot/os-prober/Manifest
+++ b/sys-boot/os-prober/Manifest
@@ -1 +1,2 @@
 DIST os-prober_1.71.tar.xz 25540 SHA256 5d6141e02b58e82194422b97d683d61c7ff78175d89c2f055f5d2e7a363bdd20 SHA512 adb7b8cf54c6169510c7ce2bf40e4b659c97eecfb7c1dd149269520ef13cdc2b6587f221fcfcb95c18caf9dba8144bbba561abb158e986ab02f4e0d338317d04 WHIRLPOOL cb3d8596c1e753fc2d687b30c6bd386d160114524b7b4f2d39dfe208191b231962311103a3106a7ccad8fa05bee132a5faa72265c44c33e22cb3d6090dd1cb04
+DIST os-prober_1.73.tar.xz 26532 SHA256 588395e38e9123f414cc1e7ea2374e4bd133bb7a8d0e0aff18acc8d7f8d23adf SHA512 7db2c276a16fefb53750889c5e784cdfe285b0124e8eb0c5dd92a9ce7addef95ef6e62d6ccd3c66788f6d1c9d029e9e98ae21040d1d84885e756691504e63ea4 WHIRLPOOL 7ed340397ff4075b28d6de5e4de347a2cbfeddaa52f4861dbe96efb7b07dda729c39f926abbdf689899cee157c0b900edcacf10c7340c6118d9b84a431a385a8
diff --git a/sys-boot/os-prober/os-prober-1.73.ebuild b/sys-boot/os-prober/os-prober-1.73.ebuild
new file mode 100644
index 000000000000..f859958a07dd
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.73.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# bug 594250
+QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
+
+src_prepare() {
+	# use default GNU rules
+	rm Makefile || die 'rm Makefile failed'
+}
+
+src_compile() {
+	tc-export CC
+	emake newns
+}
+
+src_install() {
+	dobin os-prober linux-boot-prober
+
+	# Note: as no shared libraries are installed, /usr/lib is correct
+	exeinto /usr/lib/os-prober
+	doexe newns
+
+	insinto /usr/share/os-prober
+	doins common.sh
+
+	keepdir /var/lib/os-prober
+
+	local debarch=${ARCH%-*} dir
+
+	case ${debarch} in
+		amd64)		debarch=x86 ;;
+		ppc|ppc64)	debarch=powerpc ;;
+	esac
+
+	for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+		exeinto /usr/lib/$dir
+		doexe $dir/common/*
+		if [[ -d $dir/$debarch ]]; then
+			doexe $dir/$debarch/*
+		fi
+		if [[ -d $dir/$debarch/efi ]]; then
+			exeinto /usr/lib/$dir/efi
+			doexe $dir/$debarch/efi/*
+		fi
+	done
+
+	if use amd64 || use x86; then
+		exeinto /usr/lib/os-probes/mounted
+		doexe os-probes/mounted/powerpc/20macosx
+	fi
+
+	dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+	elog "If you intend for os-prober to detect versions of Windows installed on"
+	elog "NTFS-formatted partitions, your system must be capable of reading the"
+	elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}
-- 
cgit v1.2.3-65-gdbad