summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luasocket')
-rw-r--r--dev-lua/luasocket/ChangeLog17
-rw-r--r--dev-lua/luasocket/Manifest5
-rw-r--r--dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch25
-rw-r--r--dev-lua/luasocket/luasocket-2.0.2.ebuild49
-rw-r--r--dev-lua/luasocket/metadata.xml13
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-lua/luasocket/ChangeLog b/dev-lua/luasocket/ChangeLog
new file mode 100644
index 000000000000..11d3e1c0b2e0
--- /dev/null
+++ b/dev-lua/luasocket/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for dev-lua/luasocket
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luasocket/ChangeLog,v 1.1 2010/11/05 21:31:09 rafaelmartins Exp $
+
+ 05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +luasocket-2.0.2.ebuild, +files/luasocket-2.0.2-unixsocket.patch,
+ +metadata.xml:
+ Moved from dev-libs to dev-lua.
+
+*luasocket-2.0.2 (28 Sep 2009)
+
+ 28 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +luasocket-2.0.2.ebuild, +files/luasocket-2.0.2-unixsocket.patch,
+ +metadata.xml:
+ Initial import of luasocket (needed for ekeyd); thanks to Pierre
+ Guinoiseau in bug #239540 for the basic ebuild.
+
diff --git a/dev-lua/luasocket/Manifest b/dev-lua/luasocket/Manifest
new file mode 100644
index 000000000000..d525cbe2d85c
--- /dev/null
+++ b/dev-lua/luasocket/Manifest
@@ -0,0 +1,5 @@
+AUX luasocket-2.0.2-unixsocket.patch 844 RMD160 735acde9773db8d3cfc833f077889038b194201e SHA1 56b9cd454728d145e1ba2438568bd6bc414b2ebe SHA256 63b846797304ebc1060dd22cf7e5cf63f1dc6dd3f980bccca67024e9cc8966d4
+DIST luasocket-2.0.2.tar.gz 115443 RMD160 24d7e4fb1c9cf0c3d94f8b36e82d494ae922e268 SHA1 5ce521fc5c6efb7c1eba7f36dfeafa9e4d745464 SHA256 4fd9c775cfd98841299851e29b30176caf289370fea1ff1e00bb67c2d6842ca6
+EBUILD luasocket-2.0.2.ebuild 1328 RMD160 5cf23ac9d19d57458b5b2e35cb5e7f7858dd39a1 SHA1 65dcc387cd692e4aefa6538c94286f90896c7d2b SHA256 39ad1ee9e1468006639dd739126bd142b1bd8a43ec7072f18071439ad34a24a5
+MISC ChangeLog 685 RMD160 c376362ef225728e5c95281724022d27e22044b2 SHA1 aa8e64811129769bfbe9ee4c36441360a202a2b9 SHA256 cdb4e52afa7a6f2f52aa72b5a55465dc33b8a89422712201eabf92f0e36505df
+MISC metadata.xml 459 RMD160 1c1f88a2463eb0ad60ffabdababf70f75a984ec5 SHA1 92065f6a39620fc5e1efbe85d1c460859775ab56 SHA256 9683b47c17d7327518600beebed73b5648cd0492bb81506688527fcf63b19425
diff --git a/dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch b/dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch
new file mode 100644
index 000000000000..15f4fe01496c
--- /dev/null
+++ b/dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch
@@ -0,0 +1,25 @@
+Index: luasocket-2.0.2/makefile
+===================================================================
+--- luasocket-2.0.2.orig/makefile
++++ luasocket-2.0.2/makefile
+@@ -45,6 +47,7 @@ install: all
+ #cd src; $(INSTALL_DATA) $(TO_MIME_SHARE) $(INSTALL_MIME_SHARE)
+ cd src; mkdir -p $(INSTALL_MIME_LIB)
+ cd src; $(INSTALL_EXEC) $(MIME_SO) $(INSTALL_MIME_LIB)/core.$(EXT)
++ cd src; $(INSTALL_EXEC) $(UNIX_SO) $(INSTALL_SOCKET_LIB)/unix.$(EXT)
+
+ #------
+ # End of makefile
+Index: luasocket-2.0.2/src/makefile
+===================================================================
+--- luasocket-2.0.2.orig/src/makefile
++++ luasocket-2.0.2/src/makefile
+@@ -47,7 +47,7 @@ UNIX_OBJS:=\
+ usocket.o \
+ unix.o
+
+-all: $(SOCKET_SO) $(MIME_SO)
++all: $(SOCKET_SO) $(MIME_SO) $(UNIX_SO)
+
+ $(SOCKET_SO): $(SOCKET_OBJS)
+ $(LD) $(LDFLAGS) -o $@ $(SOCKET_OBJS)
diff --git a/dev-lua/luasocket/luasocket-2.0.2.ebuild b/dev-lua/luasocket/luasocket-2.0.2.ebuild
new file mode 100644
index 000000000000..e548b9581cd5
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-2.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luasocket/luasocket-2.0.2.ebuild,v 1.1 2010/11/05 21:31:09 rafaelmartins Exp $
+
+EAPI=2
+
+inherit multilib toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="Networking support library for the Lua language."
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/"
+SRC_URI="http://luaforge.net/frs/download.php/2664/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Unix socket support is needed by app-crypt/ekeyd, but upstream
+ # does not seem to enable it by default.
+ epatch "${FILESDIR}"/${P}-unixsocket.patch
+}
+
+src_compile() {
+ # We append flags here to avoid editing the config file
+ use debug && append-flags -DLUASOCKET_DEBUG
+ append-flags -fPIC
+
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ || die
+}
+
+src_install() {
+ emake install \
+ INSTALL_TOP_SHARE="${D}/$(pkg-config --variable INSTALL_LMOD lua)" \
+ INSTALL_TOP_LIB="${D}/$(pkg-config --variable INSTALL_CMOD lua | sed -e "s:lib/:$(get_libdir)/:")" \
+ || die
+
+ dodoc NEW README || die
+ dohtml doc/* || die
+}
diff --git a/dev-lua/luasocket/metadata.xml b/dev-lua/luasocket/metadata.xml
new file mode 100644
index 000000000000..051ccf425cda
--- /dev/null
+++ b/dev-lua/luasocket/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <description>
+ I need this for app-crypt/ekeyd, if you care about this for LUA,
+ or for any other reason, you're free to pick it up; please just
+ leave the unix socket support in, thanks!
+ </description>
+ </maintainer>
+</pkgmetadata>