summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 19:28:03 -0500
committerSam James <sam@gentoo.org>2024-03-06 03:36:21 +0000
commit5274fa9a986cf63202ba3c0b4b333bd7ff894d83 (patch)
tree7a074bd30e700bc1b0a795d0a1c7d0fbe2a92085
parentdev-python/pygal: fix dependencies for doc building (diff)
downloadgentoo-5274fa9a986cf63202ba3c0b4b333bd7ff894d83.tar.gz
gentoo-5274fa9a986cf63202ba3c0b4b333bd7ff894d83.tar.bz2
gentoo-5274fa9a986cf63202ba3c0b4b333bd7ff894d83.zip
media-gfx/graphviz: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/graphviz/graphviz-9.0.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-gfx/graphviz/graphviz-9.0.0.ebuild b/media-gfx/graphviz/graphviz-9.0.0.ebuild
index db2dd159e4a5..7dc66d7742f7 100644
--- a/media-gfx/graphviz/graphviz-9.0.0.ebuild
+++ b/media-gfx/graphviz/graphviz-9.0.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit python-single-r1
+inherit libtool python-single-r1
DESCRIPTION="Open Source Graph Visualization Software"
HOMEPAGE="https://www.graphviz.org/ https://gitlab.com/graphviz/graphviz/"
@@ -141,6 +141,11 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
local myconf=(
# Speeds up the libltdl configure