summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 19:19:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 19:19:54 +0100
commit65cc953e9b4977c81feee21dae0e0bde7c5781fe (patch)
tree96a4eb464b14bf23d8479dff3e172d18fc14cb76
parentxfce-extra/xfce4-mount-plugin: Bump to 1.1.7 (diff)
downloadgentoo-65cc953e9b4977c81feee21dae0e0bde7c5781fe.tar.gz
gentoo-65cc953e9b4977c81feee21dae0e0bde7c5781fe.tar.bz2
gentoo-65cc953e9b4977c81feee21dae0e0bde7c5781fe.zip
xfce-extra/xfce4-places-plugin: Bump to 1.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index 380cbdb663f3..4b97a74c2b6f 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-places-plugin-1.8.3.tar.bz2 388661 BLAKE2B c824db5b7cfb1458c3562ab8dc1334d8fd7223ede49c62f52def23c16899848490907a044998e205a31837c96264415c9cfe2ef7adac5ddabd9f4440cafae562 SHA512 31ab8a47606c6406e93a753c55eb902fb25828f2c89c31814c11534dde327e656678ffcd590b41ebfab0a761bfcf0dae72e1ca3bb84eef5d0592f52114556ac9
+DIST xfce4-places-plugin-1.8.4.tar.bz2 452904 BLAKE2B b0a331ce87cbd170c8fbec0b2e772901550efea982bec29e3a70d72c5905c278834b4b595497720e02e1c1dee6de05dce0aeb8f316fc892ffd781991973f81e2 SHA512 41c9386989ad18fd6b3e30779c964b13db2c03c60de573397109ff745cde52e0fc4965dae365b3aac5e5ad72cf64144268621fcda5485c7b6d65de673d886fe9
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.4.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.4.ebuild
new file mode 100644
index 000000000000..df1c76a47362
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-places-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:=
+ >=xfce-base/exo-4.16.0:=
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}