summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 03:34:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:34:16 +0200
commitd16c6c2e90e6c1435c32ec7c0f4d3406b2b42f41 (patch)
treeb00b4b14e73600a2b2a8aa3d1d3950d3a99b441e
parentdev-python/automat: Bump to 24.8.1 (diff)
downloadgentoo-d16c6c2e90e6c1435c32ec7c0f4d3406b2b42f41.tar.gz
gentoo-d16c6c2e90e6c1435c32ec7c0f4d3406b2b42f41.tar.bz2
gentoo-d16c6c2e90e6c1435c32ec7c0f4d3406b2b42f41.zip
dev-python/aiohappyeyeballs: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index a9d972e82c73..add007990f07 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1,2 +1,3 @@
DIST aiohappyeyeballs-2.3.6.gh.tar.gz 55205 BLAKE2B 7359b17a21e33247ea60a21c3303464e92841b8a6dbfb7c75380ce7bcc708f2f71e1041c6d976f467f99e16e55a22f516701a5439809dec4b6910b6a70c0d119 SHA512 637ac7f0fd5433f3f01b3289924fec53742d60f7b87696d2614c34e463324165135fe4111b2afb4499ed76d08a6759721aad5a2a6e62b227f1ff38cc936e0719
DIST aiohappyeyeballs-2.3.7.gh.tar.gz 55283 BLAKE2B 4c8167fb646ed4f1b7472d170e75027abbf0b08908d4bb45d1d167403e8ff35382d654de7684750495305b09158ee3aa8951639d7c5e104ba2b4d22132c498f2 SHA512 c432e9cd9165f1f125280a78f616b09e276bfcb52ed76d498920bf0534450657f60061f4098df55dc2f9a27043ac094ce2f1431b328507173b6b35bd226a48db
+DIST aiohappyeyeballs-2.4.0.gh.tar.gz 55452 BLAKE2B 11e34818ed652b2904e78c7a48726d68118a6ecb811be8dcd5008acefd96093b8a2bf25bf92ebb79cdac4735100cec9ca05c856034900f8cda93f45be4f4d627 SHA512 8c2e931fa8b0423e1958a45ac5a040f35e9c0c4df7e4bd6662b5c0288fd25f64cce556cb386b27d07c7438b901a3468fa993c929a3b9c221fb5a318e7809db5a
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.0.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.0.ebuild
new file mode 100644
index 000000000000..05fb16344a39
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}