summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-08-24 11:58:12 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-08-24 11:58:34 +0300
commit74bfda505e3610bbc8f5a63a3aa27abd9054e7a0 (patch)
tree5542cc89854f0602335ca7787c62bb8a3269620a /app-text/zathura-cb
parentnet-libs/libsmi: Drop virtual/yacc again (diff)
downloadgentoo-74bfda505e3610bbc8f5a63a3aa27abd9054e7a0.tar.gz
gentoo-74bfda505e3610bbc8f5a63a3aa27abd9054e7a0.tar.bz2
gentoo-74bfda505e3610bbc8f5a63a3aa27abd9054e7a0.zip
app-text/zathura-cb: call xdg_desktop_database_update
Closes: https://bugs.gentoo.org/735700 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-text/zathura-cb')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.8.ebuild12
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild12
2 files changed, 20 insertions, 4 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.8.ebuild b/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
index 2fad557959ce..237c58a12477 100644
--- a/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
+++ b/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -28,3 +28,11 @@ DEPEND=">=app-text/zathura-0.3.9
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index 5e59ea0d4e25..a5d47c0a1d7a 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -28,3 +28,11 @@ DEPEND=">=app-text/zathura-0.3.9
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}