summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-02-19 16:57:40 +0000
committerSam James <sam@gentoo.org>2025-02-19 16:58:45 +0000
commitc7a1a1977307c00362a34bffa75c8a50c358426d (patch)
treecbbfc283ee8dec7cdfc71bac63e9484f3457cc26 /dev-lang/ruby
parentdev-python/executing: Enable pypy3.11 (diff)
downloadgentoo-c7a1a1977307c00362a34bffa75c8a50c358426d.tar.gz
gentoo-c7a1a1977307c00362a34bffa75c8a50c358426d.tar.bz2
gentoo-c7a1a1977307c00362a34bffa75c8a50c358426d.zip
dev-lang/ruby: fix SRC_URI
As reported at https://forums.gentoo.org/viewtopic-t-1173036.html. Fixes: 01ba4dc61965ef7658a24728841c04c9a1ce4871 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ruby-3.2.4-r2.ebuild11
-rw-r--r--dev-lang/ruby/ruby-3.2.4-r3.ebuild9
-rw-r--r--dev-lang/ruby/ruby-3.2.5-r2.ebuild11
-rw-r--r--dev-lang/ruby/ruby-3.2.6-r2.ebuild9
-rw-r--r--dev-lang/ruby/ruby-3.2.6-r3.ebuild9
-rw-r--r--dev-lang/ruby/ruby-3.2.6-r4.ebuild9
-rw-r--r--dev-lang/ruby/ruby-3.3.6-r1.ebuild11
7 files changed, 38 insertions, 31 deletions
diff --git a/dev-lang/ruby/ruby-3.2.4-r2.ebuild b/dev-lang/ruby/ruby-3.2.4-r2.ebuild
index 229a1aacf8e0..11bb88262f7d 100644
--- a/dev-lang/ruby/ruby-3.2.4-r2.ebuild
+++ b/dev-lang/ruby/ruby-3.2.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"
diff --git a/dev-lang/ruby/ruby-3.2.4-r3.ebuild b/dev-lang/ruby/ruby-3.2.4-r3.ebuild
index d01fc70c2624..3350c3c8f7ba 100644
--- a/dev-lang/ruby/ruby-3.2.4-r3.ebuild
+++ b/dev-lang/ruby/ruby-3.2.4-r3.ebuild
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"
diff --git a/dev-lang/ruby/ruby-3.2.5-r2.ebuild b/dev-lang/ruby/ruby-3.2.5-r2.ebuild
index 2ee5bd08be07..f912e9272740 100644
--- a/dev-lang/ruby/ruby-3.2.5-r2.ebuild
+++ b/dev-lang/ruby/ruby-3.2.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"
diff --git a/dev-lang/ruby/ruby-3.2.6-r2.ebuild b/dev-lang/ruby/ruby-3.2.6-r2.ebuild
index 96d5abbafa45..648fd0744bb5 100644
--- a/dev-lang/ruby/ruby-3.2.6-r2.ebuild
+++ b/dev-lang/ruby/ruby-3.2.6-r2.ebuild
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"
diff --git a/dev-lang/ruby/ruby-3.2.6-r3.ebuild b/dev-lang/ruby/ruby-3.2.6-r3.ebuild
index f29355c9117c..3e8f94cdf13c 100644
--- a/dev-lang/ruby/ruby-3.2.6-r3.ebuild
+++ b/dev-lang/ruby/ruby-3.2.6-r3.ebuild
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"
diff --git a/dev-lang/ruby/ruby-3.2.6-r4.ebuild b/dev-lang/ruby/ruby-3.2.6-r4.ebuild
index d08d1ea44138..b089d1be714b 100644
--- a/dev-lang/ruby/ruby-3.2.6-r4.ebuild
+++ b/dev-lang/ruby/ruby-3.2.6-r4.ebuild
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"
diff --git a/dev-lang/ruby/ruby-3.3.6-r1.ebuild b/dev-lang/ruby/ruby-3.3.6-r1.ebuild
index 7680cec58196..ac5614b89347 100644
--- a/dev-lang/ruby/ruby-3.3.6-r1.ebuild
+++ b/dev-lang/ruby/ruby-3.3.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,16 +8,17 @@ RUST_OPTIONAL="yes"
inherit autotools flag-o-matic multiprocessing rust
MY_P="${PN}-$(ver_cut 1-3)"
+MY_SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${MY_SLOT})
+RUBYVERSION=${MY_SLOT}.0
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="https://www.ruby-lang.org/"
-SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
+SRC_URI="https://cache.ruby-lang.org/pub/ruby/${MY_SLOT}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="|| ( Ruby-BSD BSD-2 )"
-SLOT=$(ver_cut 1-2)
-MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
-RUBYVERSION=${SLOT}.0
+SLOT=${MY_SLOT}
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="berkdb debug doc examples gdbm jemalloc jit socks5 +ssl static-libs systemtap tk valgrind xemacs"