summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/re2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/re2')
-rw-r--r--dev-libs/re2/Manifest3
-rw-r--r--dev-libs/re2/files/re2-compile-r0.patch27
-rw-r--r--dev-libs/re2/files/re2-symbols-r0.patch10
-rw-r--r--dev-libs/re2/metadata.xml5
-rw-r--r--dev-libs/re2/re2-0_p20130115-r1.ebuild56
-rw-r--r--dev-libs/re2/re2-0_p20130115.ebuild47
-rw-r--r--dev-libs/re2/re2-0_p20130712.ebuild52
-rw-r--r--dev-libs/re2/re2-0_p20140304.ebuild45
8 files changed, 245 insertions, 0 deletions
diff --git a/dev-libs/re2/Manifest b/dev-libs/re2/Manifest
new file mode 100644
index 000000000000..9abfb96333e6
--- /dev/null
+++ b/dev-libs/re2/Manifest
@@ -0,0 +1,3 @@
+DIST re2-20130115.tgz 1020951 SHA256 a95d83ed8203817587f7cc368b6f7199d8a4b1558372c306b07201058b92e1fe SHA512 ef1378d89397bf594ece7817ef91171e467a3408046f769eca08beba900a0e70f652e7c4e3b667b3a9d5cef044b08ed74ef7d564ffb965ab75bb9a3964c9ab5a WHIRLPOOL 2cbf47b1816e35e5c7f359a310b4421ad635d1513167ffabf98db84397be800f8b98d4808705754f0e2db14bbeb0d62e47ac3abb385e299c503126a9f874daf5
+DIST re2-20130712.tgz 1028311 SHA256 c30e43524280ebc2b9afa8c40ad477d0b2665bc81b663e9ae1b8b48e053af54b SHA512 910e7c7f5b3268746355c2e14dc6a4e32105207abcf8cb56b76fc554be41768e4e4a6b526c9335e95be0bb111025876b61ede1cfebcbec4a4062d53bb1448e08 WHIRLPOOL e5cf26a6c8586503c1639dd3f528cace8a4d7ca4c4ff97e08b12f45753ff67ad78656513658eabd678ac8ab88f1de5279960428fffe1b9e0535afdba44e7e8a3
+DIST re2-20140304.tgz 1050493 SHA256 0bffd1a57de2f4b218ca0f77d8850bfd59c82944a98256c6edba25260e0196a7 SHA512 a426e8d69d2c7614087990180539c5b1aa2c544dee14b144098f810b76b6062d7de9efaf1e90e83c61c8e4382a066201862d09965f1a6a9f86e2912011ad9d40 WHIRLPOOL d998a6dd9edac52fe0c4ed7e895940380d9b67220711d68aed02294c8f65a644a59f77bddce116ccf79860c633046fa2b5060ef45d5cb5ea5bc0c1965cdce052
diff --git a/dev-libs/re2/files/re2-compile-r0.patch b/dev-libs/re2/files/re2-compile-r0.patch
new file mode 100644
index 000000000000..cf2c8c0d5717
--- /dev/null
+++ b/dev-libs/re2/files/re2-compile-r0.patch
@@ -0,0 +1,27 @@
+--- util/mutex.h.orig 2013-09-22 13:24:25.126582479 -0500
++++ util/mutex.h 2013-09-22 13:25:11.376179517 -0500
+@@ -10,6 +10,8 @@
+ #ifndef RE2_UTIL_MUTEX_H_
+ #define RE2_UTIL_MUTEX_H_
+
++#include <stdlib.h>
++
+ namespace re2 {
+
+ #define HAVE_PTHREAD 1
+@@ -102,7 +104,6 @@
+
+ #elif defined(HAVE_PTHREAD) && defined(HAVE_RWLOCK)
+
+-#include <stdlib.h> // for abort()
+ #define SAFE_PTHREAD(fncall) do { if ((fncall) != 0) abort(); } while (0)
+
+ Mutex::Mutex() { SAFE_PTHREAD(pthread_rwlock_init(&mutex_, NULL)); }
+@@ -117,7 +118,6 @@
+
+ #elif defined(HAVE_PTHREAD)
+
+-#include <stdlib.h> // for abort()
+ #define SAFE_PTHREAD(fncall) do { if ((fncall) != 0) abort(); } while (0)
+
+ Mutex::Mutex() { SAFE_PTHREAD(pthread_mutex_init(&mutex_, NULL)); }
diff --git a/dev-libs/re2/files/re2-symbols-r0.patch b/dev-libs/re2/files/re2-symbols-r0.patch
new file mode 100644
index 000000000000..1fb9f2e35c45
--- /dev/null
+++ b/dev-libs/re2/files/re2-symbols-r0.patch
@@ -0,0 +1,10 @@
+--- libre2.symbols.orig 2012-11-07 04:45:57.000000000 +0100
++++ libre2.symbols 2012-11-07 04:46:20.000000000 +0100
+@@ -10,6 +10,7 @@
+ _ZlsRSoRKN3re211StringPieceE;
+ # re2::FilteredRE2*
+ _ZN3re211FilteredRE2*;
++ _ZNK3re211FilteredRE2*;
+ local:
+ *;
+ };
diff --git a/dev-libs/re2/metadata.xml b/dev-libs/re2/metadata.xml
new file mode 100644
index 000000000000..fffcfc8b794e
--- /dev/null
+++ b/dev-libs/re2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>chromium</herd>
+</pkgmetadata>
diff --git a/dev-libs/re2/re2-0_p20130115-r1.ebuild b/dev-libs/re2/re2-0_p20130115-r1.ebuild
new file mode 100644
index 000000000000..d4ed307c4bba
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20130115-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib multilib-build toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Fix problems with FilteredRE2 symbols not being exported.
+ epatch "${FILESDIR}/${PN}-symbols-r0.patch"
+ multilib_copy_sources
+}
+
+mymake() {
+ cd "${BUILD_DIR}" || die
+ local makeopts=(
+ AR="$(tc-getAR)"
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS} -pthread"
+ LDFLAGS="${LDFLAGS} -pthread"
+ NM="$(tc-getNM)"
+ )
+ emake "${makeopts[@]}" "$@"
+}
+
+src_compile() {
+ multilib_foreach_abi mymake
+}
+
+src_test() {
+ multilib_foreach_abi mymake shared-test
+}
+
+src_install() {
+ myinstall() {
+ cd "${BUILD_DIR}" || die
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+ multilib_check_headers
+ }
+ multilib_foreach_abi myinstall
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}
diff --git a/dev-libs/re2/re2-0_p20130115.ebuild b/dev-libs/re2/re2-0_p20130115.ebuild
new file mode 100644
index 000000000000..fc79ab11106a
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20130115.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Fix problems with FilteredRE2 symbols not being exported.
+ epatch "${FILESDIR}/${PN}-symbols-r0.patch"
+}
+
+src_compile() {
+ makeopts=(
+ AR="$(tc-getAR)"
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS} -pthread"
+ LDFLAGS="${LDFLAGS} -pthread"
+ NM="$(tc-getNM)"
+ )
+ emake "${makeopts[@]}"
+}
+
+src_test() {
+ emake "${makeopts[@]}" shared-test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+ # TODO: the upstream should not build static library at all.
+ rm "${ED}/usr/$(get_libdir)/libre2.a" || die
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}
diff --git a/dev-libs/re2/re2-0_p20130712.ebuild b/dev-libs/re2/re2-0_p20130712.ebuild
new file mode 100644
index 000000000000..45face3005b4
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20130712.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib multilib-minimal toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-compile-r0.patch"
+ multilib_copy_sources
+}
+
+mymake() {
+ local makeopts=(
+ AR="$(tc-getAR)"
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS} -pthread"
+ LDFLAGS="${LDFLAGS} -pthread"
+ NM="$(tc-getNM)"
+ )
+ emake "${makeopts[@]}" "$@"
+}
+
+multilib_src_compile() {
+ mymake
+}
+
+multilib_src_test() {
+ mymake static-test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}
diff --git a/dev-libs/re2/re2-0_p20140304.ebuild b/dev-libs/re2/re2-0_p20140304.ebuild
new file mode 100644
index 000000000000..9496910e814e
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20140304.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils multilib multilib-minimal toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+# Symbols removed in version 20140110
+# http://upstream-tracker.org/compat_reports/re2/20131024_to_20140110/abi_compat_report.html
+# https://code.google.com/p/re2/issues/detail?id=111
+SLOT="0/0.20140110"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+src_configure() {
+ tc-export AR CXX NM
+ append-cxxflags -pthread
+ append-ldflags -pthread
+}
+
+multilib_src_test() {
+ emake static-test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}