summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-18 19:23:20 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:50:38 +0200
commitd205413985c21b7d1bea22dc1d75a86fd5079415 (patch)
tree08c6d6a330e2b6b9b1f889520aec04f68063b64c /dev-ml/camlidl
parentdev-libs/level-zero: remove unused patch(es) (diff)
downloadgentoo-d205413985c21b7d1bea22dc1d75a86fd5079415.tar.gz
gentoo-d205413985c21b7d1bea22dc1d75a86fd5079415.tar.bz2
gentoo-d205413985c21b7d1bea22dc1d75a86fd5079415.zip
dev-ml/camlidl: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-ml/camlidl')
-rw-r--r--dev-ml/camlidl/files/camlidl-1.09.parallelMake.patch12
-rw-r--r--dev-ml/camlidl/files/includes.patch10
-rw-r--r--dev-ml/camlidl/files/tests.patch34
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-ml/camlidl/files/camlidl-1.09.parallelMake.patch b/dev-ml/camlidl/files/camlidl-1.09.parallelMake.patch
deleted file mode 100644
index 1a6df0f21f5e..000000000000
--- a/dev-ml/camlidl/files/camlidl-1.09.parallelMake.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/tests/Makefile 2023-01-19 21:02:36.678227862 +0100
-+++ b/tests/Makefile 2023-01-19 21:03:01.140832955 +0100
-@@ -11,7 +11,8 @@
- COMLIBS=$(COMLIBS_$(OSTYPE))
- COMLIBS_win32=advapi32.lib ole32.lib oleaut32.lib
-
--all: ../caml/camlidlruntime.h $(TESTS:.idl=.$(OBJEXT)) testcomp
-+all: ../caml/camlidlruntime.h
-+ $(MAKE) $(TESTS:.idl=.$(OBJEXT)) testcomp
-
- $(TESTS:.idl=.$(OBJEXT)) component.$(OBJEXT): $(CAMLIDL) ../runtime/camlidlruntime.h
-
diff --git a/dev-ml/camlidl/files/includes.patch b/dev-ml/camlidl/files/includes.patch
deleted file mode 100644
index 077ba21d93da..000000000000
--- a/dev-ml/camlidl/files/includes.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/runtime/comerror.c
-+++ b/runtime/comerror.c
-@@ -22,6 +22,7 @@
- #include <caml/callback.h>
- #include <caml/fail.h>
- #include <caml/alloc.h>
-+#include <caml/printexc.h>
- #include "camlidlruntime.h"
- #include "comstuff.h"
-
diff --git a/dev-ml/camlidl/files/tests.patch b/dev-ml/camlidl/files/tests.patch
deleted file mode 100644
index f8c4595f9fbd..000000000000
--- a/dev-ml/camlidl/files/tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/tests/unix.idl
-+++ b/tests/unix.idl
-@@ -15,16 +15,16 @@ quote (C, "
-
- union process_status { int code; };
-
-- enum { WEXITED, WSIGNALED, WSTOPPED };
-+ enum { WEXITED2, WSIGNALED, WSTOPPED2 };
-
- static void decode_status(int status, int * kind, union process_status * p)
- {
- if (WIFEXITED(status)) {
-- *kind = WEXITED; p->code = WEXITSTATUS(status);
-+ *kind = WEXITED2; p->code = WEXITSTATUS(status);
- } else if (WIFSIGNALED(status)) {
- *kind = WSIGNALED; p->code = WTERMSIG(status);
- } else {
-- *kind = WSTOPPED; p->code = WSTOPSIG(status);
-+ *kind = WSTOPPED2; p->code = WSTOPSIG(status);
- }
- }
-
-@@ -59,9 +59,9 @@ int execve([in,string] char * path,
- int fork(void);
-
- union process_status {
-- case WEXITED: int code;
-+ case WEXITED2: int code;
- case WSIGNALED: int code;
-- case WSTOPPED: int code;
-+ case WSTOPPED2: int code;
- };
-
- int wait([out] int * kind,