summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-22 14:11:43 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-22 14:12:09 +1300
commit4e7bb72e89d1bba15f175e39c9bcebb42e7cf8f1 (patch)
treef8582e9170b1d18b122f66859aba1672c0f1e4e1 /dev-perl/frontier-rpc
parentdev-perl/forks: EAPI6 / Metadata (diff)
downloadgentoo-4e7bb72e89d1bba15f175e39c9bcebb42e7cf8f1.tar.gz
gentoo-4e7bb72e89d1bba15f175e39c9bcebb42e7cf8f1.tar.bz2
gentoo-4e7bb72e89d1bba15f175e39c9bcebb42e7cf8f1.zip
dev-perl/frontier-rpc: EAPI6 + Tests
- EAPI6ify - Enable tests Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/frontier-rpc')
-rw-r--r--dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild b/dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild
new file mode 100644
index 000000000000..f34439cff25e
--- /dev/null
+++ b/dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_NAME=Frontier-RPC
+DIST_VERSION=0.07b4
+DIST_AUTHOR=KMACLEOD
+inherit perl-module
+
+DESCRIPTION="Perform remote procedure calls using extensible markup language"
+SRC_URI+=" http://perl-xml.sourceforge.net/xml-rpc/${DIST_NAME}-${DIST_VERSION}.tar.gz"
+HOMEPAGE+=" http://perl-xml.sourceforge.net/xml-rpc/"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+"
+DEPEND="${RDEPEND}"