summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-07-01 08:16:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-07-01 08:17:08 +0200
commit76939d33e33ad3d0604486bd76146aa5966c1d1b (patch)
tree1a3e1d089724204e52623b67a343954f021758a1 /dev-python/brython
parentapp-shells/hstr: version and EAPI 7 bump. (diff)
downloadgentoo-76939d33e33ad3d0604486bd76146aa5966c1d1b.tar.gz
gentoo-76939d33e33ad3d0604486bd76146aa5966c1d1b.tar.bz2
gentoo-76939d33e33ad3d0604486bd76146aa5966c1d1b.zip
dev-python/brython: version bump.
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.7.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index c6a694f3d44d..1f41f7bbb216 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1 +1,2 @@
DIST brython-3.7.3.tar.gz 10403156 BLAKE2B a30c957925149f1b7eb736c1fcacd171dffb5846f6a343227596e759820c794c265befbb04137e797c1eabe8d9f0a3faa93fe425e4b0c13fda4c78b4c4bb1ecd SHA512 f234c7bc67d935e5bd5bfa8e473bccf90245ab4dabccd363bc5e9e01e1c9ea9d95989c5f8b323c158e286ac4a66106eb07722d1fcc82353ad036e35b4fda5669
+DIST brython-3.7.4.tar.gz 10473351 BLAKE2B c457498d7f9b61ef416d6ec0ccbf86e3fdc7cc55f90fd8a853005285cab814d054319a5437cc24d22d6088af6f5b58da5311c6f68721d7b243fe31ef450c38a1 SHA512 70959debdd0a3e7f7e533f17aa2149802454bee23598d844156756ee6aab697b75337a26a341e6408966036f419696d0f8b073cb5383f32a9f6de65cde2fa40a
diff --git a/dev-python/brython/brython-3.7.4.ebuild b/dev-python/brython/brython-3.7.4.ebuild
new file mode 100644
index 000000000000..ce838901b946
--- /dev/null
+++ b/dev-python/brython/brython-3.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}