summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 11:59:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 11:59:36 +0100
commit54c0b784609caf77eb3053360bc630468fec2e75 (patch)
treeea61e23cf68103711eb879f48fd5233b16c047b9 /dev-python/gitdb
parentdev-python/types-setuptools: Stabilize 68.2.0.1 arm64, #917716 (diff)
downloadgentoo-54c0b784609caf77eb3053360bc630468fec2e75.tar.gz
gentoo-54c0b784609caf77eb3053360bc630468fec2e75.tar.bz2
gentoo-54c0b784609caf77eb3053360bc630468fec2e75.zip
dev-python/gitdb: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/Manifest1
-rw-r--r--dev-python/gitdb/gitdb-4.0.10-r1.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/gitdb/Manifest b/dev-python/gitdb/Manifest
index becf6e0a2d38..12b6ea50c6d3 100644
--- a/dev-python/gitdb/Manifest
+++ b/dev-python/gitdb/Manifest
@@ -1,2 +1 @@
-DIST gitdb-4.0.10.tar.gz 394284 BLAKE2B f5a00dd3a27a17781df4c53c268c92101838ce53efcb3796a72a79f8109540912f86d746cad169ef34af2575cfb242e90cb450b658699512d37956f6902e14ed SHA512 6cfb58db322f1b18fd25d0c6537e5b24b2eb2f7a7222c1511cdee8dff39fb1249bf12691b9cb1a5d653131b8c3c57c1de2bb42139a2c8da6014332b4f1c6c03b
DIST gitdb-4.0.11.tar.gz 394469 BLAKE2B a79caf7def6094f1c99ff8621d7a01a9bc438e3ff54c73e5e9f598fada892e0209334edf73415476e31aef1cd0cd344fba6c8fe11c80cc157fdef5b9d2cda292 SHA512 024256481c553cd8e4b7fb0c0adc735aa6485c396e43aba73873cd4ad950ca686c3df7000a85acd1ac4f09db3f6ab613018739d24a8a69b4708150c171acf13d
diff --git a/dev-python/gitdb/gitdb-4.0.10-r1.ebuild b/dev-python/gitdb/gitdb-4.0.10-r1.ebuild
deleted file mode 100644
index 29f1be530228..000000000000
--- a/dev-python/gitdb/gitdb-4.0.10-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="GitDB is a pure-Python git object database"
-HOMEPAGE="
- https://github.com/gitpython-developers/gitdb/
- https://pypi.org/project/gitdb/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e 's:,<[0-9.]*::' setup.py || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- local i
-
- mkdir "${T}"/repo || die
- cd "${T}"/repo || die
-
- for (( i = 0; i < 2500; ++i )); do
- echo "${i}" > file"${i}" || die
- done
-
- git init || die
- git config user.email "you@example.com" || die
- git config user.name "Your Name" || die
- git add -A || die
- git commit -q -m ".." || die
- git clone --bare "${T}"/repo "${T}"/repo.git || die
- cd "${S}" || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- gitdb/test/performance
- )
- local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
- epytest
-}