summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 07:27:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 07:32:08 +0100
commitf5ff0a8ea2622d8f3f522054c1f9c82061dbc04f (patch)
tree8636e675a9e371f2a1b2c64a99b79af07e77f170 /dev-python/numpy
parentdev-python/dulwich: Support Rust extensions (diff)
downloadgentoo-f5ff0a8ea2622d8f3f522054c1f9c82061dbc04f.tar.gz
gentoo-f5ff0a8ea2622d8f3f522054c1f9c82061dbc04f.tar.bz2
gentoo-f5ff0a8ea2622d8f3f522054c1f9c82061dbc04f.zip
dev-python/numpy: Add deselects for hppa
Closes: https://bugs.gentoo.org/942689 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-2.0.2-r1.ebuild23
-rw-r--r--dev-python/numpy/numpy-2.1.2.ebuild19
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/numpy/numpy-2.0.2-r1.ebuild b/dev-python/numpy/numpy-2.0.2-r1.ebuild
index 16b2628f9896..7b860b89e703 100644
--- a/dev-python/numpy/numpy-2.0.2-r1.ebuild
+++ b/dev-python/numpy/numpy-2.0.2-r1.ebuild
@@ -114,8 +114,29 @@ python_test() {
_core/tests/test_function_base.py::TestLinspace::test_denormal_numbers
f2py/tests/test_kind.py::TestKind::test_real
f2py/tests/test_kind.py::TestKind::test_quad_precision
+
+ # require too much memory
+ '_core/tests/test_multiarray.py::TestDot::test_huge_vectordot[complex128]'
+ '_core/tests/test_multiarray.py::TestDot::test_huge_vectordot[float64]'
)
- ;&
+ ;;
+ hppa)
+ EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/942689
+ "_core/tests/test_dtype.py::TestBuiltin::test_dtype[int]"
+ "_core/tests/test_dtype.py::TestBuiltin::test_dtype[float]"
+ f2py/tests/test_kind.py::TestKind::test_real
+ f2py/tests/test_kind.py::TestKind::test_quad_precision
+ tests/test_ctypeslib.py::TestAsArray::test_reference_cycles
+ tests/test_ctypeslib.py::TestAsArray::test_segmentation_fault
+ tests/test_ctypeslib.py::TestAsCtypesType::test_scalar
+ tests/test_ctypeslib.py::TestAsCtypesType::test_subarray
+ tests/test_ctypeslib.py::TestAsCtypesType::test_structure
+ tests/test_ctypeslib.py::TestAsCtypesType::test_structure_aligned
+ tests/test_ctypeslib.py::TestAsCtypesType::test_union
+ tests/test_ctypeslib.py::TestAsCtypesType::test_padded_union
+ )
+ ;;
ppc|x86)
EPYTEST_DESELECT+=(
# require too much memory
diff --git a/dev-python/numpy/numpy-2.1.2.ebuild b/dev-python/numpy/numpy-2.1.2.ebuild
index ddb5d3e4058f..0382087fb9cb 100644
--- a/dev-python/numpy/numpy-2.1.2.ebuild
+++ b/dev-python/numpy/numpy-2.1.2.ebuild
@@ -114,7 +114,24 @@ python_test() {
'numpy/_core/tests/test_multiarray.py::TestDot::test_huge_vectordot[complex128]'
'numpy/_core/tests/test_multiarray.py::TestDot::test_huge_vectordot[float64]'
)
- ;&
+ ;;
+ hppa)
+ EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/942689
+ "numpy/_core/tests/test_dtype.py::TestBuiltin::test_dtype[int]"
+ "numpy/_core/tests/test_dtype.py::TestBuiltin::test_dtype[float]"
+ numpy/f2py/tests/test_kind.py::TestKind::test_real
+ numpy/f2py/tests/test_kind.py::TestKind::test_quad_precision
+ numpy/tests/test_ctypeslib.py::TestAsArray::test_reference_cycles
+ numpy/tests/test_ctypeslib.py::TestAsArray::test_segmentation_fault
+ numpy/tests/test_ctypeslib.py::TestAsCtypesType::test_scalar
+ numpy/tests/test_ctypeslib.py::TestAsCtypesType::test_subarray
+ numpy/tests/test_ctypeslib.py::TestAsCtypesType::test_structure
+ numpy/tests/test_ctypeslib.py::TestAsCtypesType::test_structure_aligned
+ numpy/tests/test_ctypeslib.py::TestAsCtypesType::test_union
+ numpy/tests/test_ctypeslib.py::TestAsCtypesType::test_padded_union
+ )
+ ;;
ppc|x86)
EPYTEST_DESELECT+=(
# require too much memory