summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-10-22 02:21:25 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-10-22 02:44:37 -0400
commitfc563957c93c4f24aebe26f45a8c8be836edb118 (patch)
tree7d68823ed5ed62aec08247d77df0722a232afaa8 /dev-python/numpy
parentdev-ruby/serverengine: add 2.4.0 (diff)
downloadgentoo-fc563957c93c4f24aebe26f45a8c8be836edb118.tar.gz
gentoo-fc563957c93c4f24aebe26f45a8c8be836edb118.tar.bz2
gentoo-fc563957c93c4f24aebe26f45a8c8be836edb118.zip
dev-python/numpy: mark implicit function decl as FP
Checks for intrinsics support via a function call style that will correctly fail to link if not available. Closes: https://bugs.gentoo.org/925367 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-1.26.4.ebuild5
-rw-r--r--dev-python/numpy/numpy-2.0.0.ebuild5
-rw-r--r--dev-python/numpy/numpy-2.0.2.ebuild5
-rw-r--r--dev-python/numpy/numpy-2.1.1.ebuild5
-rw-r--r--dev-python/numpy/numpy-2.1.2.ebuild5
5 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/numpy/numpy-1.26.4.ebuild b/dev-python/numpy/numpy-1.26.4.ebuild
index 9f82b9383db2..56f02ed4ab4c 100644
--- a/dev-python/numpy/numpy-1.26.4.ebuild
+++ b/dev-python/numpy/numpy-1.26.4.ebuild
@@ -50,6 +50,11 @@ BDEPEND="
)
"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # https://bugs.gentoo.org/925367
+ vrndq_f32
+)
+
EPYTEST_XDIST=1
distutils_enable_tests pytest
diff --git a/dev-python/numpy/numpy-2.0.0.ebuild b/dev-python/numpy/numpy-2.0.0.ebuild
index be5fcd31bbdb..b5ebbb001efe 100644
--- a/dev-python/numpy/numpy-2.0.0.ebuild
+++ b/dev-python/numpy/numpy-2.0.0.ebuild
@@ -48,6 +48,11 @@ BDEPEND="
)
"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # https://bugs.gentoo.org/925367
+ vrndq_f32
+)
+
EPYTEST_XDIST=1
distutils_enable_tests pytest
diff --git a/dev-python/numpy/numpy-2.0.2.ebuild b/dev-python/numpy/numpy-2.0.2.ebuild
index 9303f488ae6b..36b49c01956b 100644
--- a/dev-python/numpy/numpy-2.0.2.ebuild
+++ b/dev-python/numpy/numpy-2.0.2.ebuild
@@ -48,6 +48,11 @@ BDEPEND="
)
"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # https://bugs.gentoo.org/925367
+ vrndq_f32
+)
+
EPYTEST_XDIST=1
distutils_enable_tests pytest
diff --git a/dev-python/numpy/numpy-2.1.1.ebuild b/dev-python/numpy/numpy-2.1.1.ebuild
index c90d9636868d..c65ca99ea528 100644
--- a/dev-python/numpy/numpy-2.1.1.ebuild
+++ b/dev-python/numpy/numpy-2.1.1.ebuild
@@ -48,6 +48,11 @@ BDEPEND="
)
"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # https://bugs.gentoo.org/925367
+ vrndq_f32
+)
+
EPYTEST_XDIST=1
distutils_enable_tests pytest
diff --git a/dev-python/numpy/numpy-2.1.2.ebuild b/dev-python/numpy/numpy-2.1.2.ebuild
index 1cab76b3b2db..b2c954fbd4cb 100644
--- a/dev-python/numpy/numpy-2.1.2.ebuild
+++ b/dev-python/numpy/numpy-2.1.2.ebuild
@@ -48,6 +48,11 @@ BDEPEND="
)
"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # https://bugs.gentoo.org/925367
+ vrndq_f32
+)
+
EPYTEST_XDIST=1
distutils_enable_tests pytest