summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-08-16 12:47:47 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-08-16 13:02:50 +0200
commit91fa2dae233587597dced8ad951faa559b8fdc4d (patch)
tree692fcd1035e927c1a03f71c37a5ec0948f54769d /dev-python/pdoc3
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.141 (diff)
downloadgentoo-91fa2dae233587597dced8ad951faa559b8fdc4d.tar.gz
gentoo-91fa2dae233587597dced8ad951faa559b8fdc4d.tar.bz2
gentoo-91fa2dae233587597dced8ad951faa559b8fdc4d.zip
dev-python/pdoc3: add 0.10.0
Compared to the previous version ebuild (0.9.2) in the 0.10.0 ebuild the unnecessary dev-python/wheel DEPEND was removed, the tests are now enabled and PYTHON_COMPAT minimum is now 3.8 (which allowed DISTUTILS_USE_SETUPTOOLS=rdepend to be dropped). Thanks to mgorny for spotting the superfluous wheel dependency. Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-python/pdoc3')
-rw-r--r--dev-python/pdoc3/Manifest1
-rw-r--r--dev-python/pdoc3/pdoc3-0.10.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pdoc3/Manifest b/dev-python/pdoc3/Manifest
index 82043ca9081d..c61bc62a1d02 100644
--- a/dev-python/pdoc3/Manifest
+++ b/dev-python/pdoc3/Manifest
@@ -1 +1,2 @@
+DIST pdoc3-0.10.0.tar.gz 86133 BLAKE2B 3bada6fb1b048c4eff7556108c29d7f92ee988332d160c4ff765c47bf0cf7a461ed90f93e7be25a7a3251f5d3e70492d23be7230a5ec4abb12612b7e0dd4b5b6 SHA512 646ffb9bceb4456a1ab36c840eb384858aab430443905bc71e62e9c71112a769b69e22cbd18a9d75b7968e2336cbbaa9072103f96dc2d0829ccc7515b057ca85
DIST pdoc3-0.9.2.tar.gz 84803 BLAKE2B 5ff52a630722b9504d1de83bb236aaaafde95417ac163b79b3585156484a12b71a16de55d00ab7377b9e44eec7902384f1f648a514b8e7392da6f5e79f6f229f SHA512 653231a124239ec189dc5aa4dec59245c6d20e4ff6ca9cb7fa468410b712b766288f4c59f8c0d0b8c1a4190ce84603455ec0ad7c7b1e0dc4f28cd279bb69685f
diff --git a/dev-python/pdoc3/pdoc3-0.10.0.ebuild b/dev-python/pdoc3/pdoc3-0.10.0.ebuild
new file mode 100644
index 000000000000..7769b43281fc
--- /dev/null
+++ b/dev-python/pdoc3/pdoc3-0.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Auto-generate API documentation for Python projects"
+HOMEPAGE="https://pdoc3.github.io/pdoc/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i \
+ -e "/setuptools_git/d" \
+ -e "/setuptools_scm/d" \
+ setup.py || die
+}
+
+distutils_enable_tests unittest