summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 14:21:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:06 +0100
commita7d11497367540f7e0484faa3d3f97be3fad0ba4 (patch)
tree07660bd6e9d532026e8d608a13a2712e27f6faa0 /dev-python/precis-i18n
parentdev-python/pybind11: Bump to 2.10.3 (diff)
downloadgentoo-a7d11497367540f7e0484faa3d3f97be3fad0ba4.tar.gz
gentoo-a7d11497367540f7e0484faa3d3f97be3fad0ba4.tar.bz2
gentoo-a7d11497367540f7e0484faa3d3f97be3fad0ba4.zip
dev-python/precis-i18n: Bump to 1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/precis-i18n')
-rw-r--r--dev-python/precis-i18n/Manifest1
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
index a6c0d4b98a98..2a8d43c1ebe6 100644
--- a/dev-python/precis-i18n/Manifest
+++ b/dev-python/precis-i18n/Manifest
@@ -1 +1,2 @@
DIST precis_i18n-1.0.4.tar.gz 67599 BLAKE2B db1f614b46015741b9f511b9a5df12e44b960ffb247357bf8d2e9f3a1deea9d417eed937e6c9e6a34d19a22c3e6d87bf8f2314767cd02b15cba068759588896f SHA512 f57840cffe1224d282e707f6a36ebd53b539f9acee58de7053f28ceed5356bd35627d7c205cc91dc81983925cca55138715051c0ca535ca1dcc9d26aad9a9353
+DIST precis_i18n-1.0.5.tar.gz 67710 BLAKE2B 7995c3cb74290524d70ecd75b052201df49ae7e9f4d0052c8176756866ba8533d164b057f0fc4c5c47b938a20e36898cb52bec411b56461cb9c4e4f7029db4ed SHA512 ba3b43d4a84de02e002f7e62a7fb75c4694f3c6a8963e5bdfd9927989c2ee84317fc5fa6f119e79bb1f88dc97a37a06930829daae3969d6a5b2f5ba57bedc3e9
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.5.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.5.ebuild
new file mode 100644
index 000000000000..0084cb86b3b0
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="
+ https://github.com/byllyfish/precis_i18n/
+ https://pypi.org/project/precis-i18n/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}