summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-13 06:21:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-13 07:15:10 +0100
commit0c914f97e4492f91a7ec592490e5c77bc8bb0aea (patch)
treec94123fd7c9dd82dfe5eaa9a5e41a15ac5626a1b /dev-python/pytest-freezer
parentdev-python/cramjam: Bump to 2.9.1 (diff)
downloadgentoo-0c914f97e4492f91a7ec592490e5c77bc8bb0aea.tar.gz
gentoo-0c914f97e4492f91a7ec592490e5c77bc8bb0aea.tar.bz2
gentoo-0c914f97e4492f91a7ec592490e5c77bc8bb0aea.zip
dev-python/pytest-freezer: Bump to 0.4.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-freezer')
-rw-r--r--dev-python/pytest-freezer/Manifest1
-rw-r--r--dev-python/pytest-freezer/pytest-freezer-0.4.9.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-freezer/Manifest b/dev-python/pytest-freezer/Manifest
index 9c333fe2a3f0..98fb3f0efcc8 100644
--- a/dev-python/pytest-freezer/Manifest
+++ b/dev-python/pytest-freezer/Manifest
@@ -1 +1,2 @@
DIST pytest_freezer-0.4.8.tar.gz 3212 BLAKE2B b16aa51c6a77f639eddf95c0a7e26c02f36b039b327ff86835f6223e5cc46c9d77c563705644d91f96310f2dd892182262c2c2cf6d85cf8d711387ca8eed7cb2 SHA512 b5b3665dcc0400787ea61be3ea59437e126325697874e4190abd9821f9c5a5620ca6af3602721fb7b777037fc191aef6aac37be5d00cc38e7c2de808cdf5bf67
+DIST pytest_freezer-0.4.9.tar.gz 3177 BLAKE2B 77c0c115adf2c10e8078d5117213a857ee838665b59344d155f2ba1f6ed1a8ba55fa877cd5cee333ec62f39f44b2acd2e2863c593d498f041087f9ecf9de684a SHA512 cbe874b4f855a7badfdf214f53a5af403ca99445e66b62ec4a26ee1da72dfe2ec280d2c0b9263fb1a398654e7214418956b4f68421e1689a7cfb3b9ed9a1b124
diff --git a/dev-python/pytest-freezer/pytest-freezer-0.4.9.ebuild b/dev-python/pytest-freezer/pytest-freezer-0.4.9.ebuild
new file mode 100644
index 000000000000..45d5d4d5b370
--- /dev/null
+++ b/dev-python/pytest-freezer/pytest-freezer-0.4.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} python3_13t )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin providing a fixture interface for spulec/freezegun"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-freezer/
+ https://pypi.org/project/pytest-freezer/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/freezegun-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest