summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-03 09:57:16 +0100
committerSam James <sam@gentoo.org>2023-05-03 09:57:48 +0100
commit71d9b18102051a5242be6160b715e8c8fe830b51 (patch)
tree05bcfb037c0e91a6da9c085d13c9353dc9d413b0 /dev-python/pythran
parentapp-arch/wimlib: add 1.14.1 (diff)
downloadgentoo-71d9b18102051a5242be6160b715e8c8fe830b51.tar.gz
gentoo-71d9b18102051a5242be6160b715e8c8fe830b51.tar.bz2
gentoo-71d9b18102051a5242be6160b715e8c8fe830b51.zip
dev-python/pythran: add 0.13.1
Closes: https://bugs.gentoo.org/905396 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest1
-rw-r--r--dev-python/pythran/pythran-0.13.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 05ff64598680..969f78d811c1 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1 +1,2 @@
DIST pythran-0.12.1.gh.tar.gz 3631063 BLAKE2B c680639a88cd63398f88ee6f5325da288c06549bfef2ee649e27dd92114a2690f54fb3da730c4eb30ff9b7ef297c219bafa5f7f7153b7710d348859a04716e84 SHA512 05c4e1d03de3eebccbb915e13c70a36de293152aece58066f2d91d483d3ac920d61c7a76adcb2337f60e637734451775f0fc61341b0ef9fc4f074a752e39de9d
+DIST pythran-0.13.1.gh.tar.gz 3639196 BLAKE2B 8aba73c68542d69dd2287d7081226161ecade9e49fe6ea69d034f9116becbc148614212cbcff0056291809d2994caf43ee374393939e44635c6bed69220b29b8 SHA512 2497fa49d78ff64e577816f4b48bd424c03f04b7605c92d359f0f8514aaa67b30b7e68248db475c215deafaf7e55f7b4b74ab37c9dbef2a27e813878bf350e77
diff --git a/dev-python/pythran/pythran-0.13.1.ebuild b/dev-python/pythran/pythran-0.13.1.ebuild
new file mode 100644
index 000000000000..5a5de404c14c
--- /dev/null
+++ b/dev-python/pythran/pythran-0.13.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{9..11} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/
+"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/boost
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ !!dev-python/setuptools-declarative-requirements
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # TODO: package xsimd then set no_xsimd = True
+ cat >> setup.cfg <<-EOF
+ [build_py]
+ no_boost = True
+ EOF
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ pythran/tests/test_xdoc.py::TestDoctest::test_cli
+ pythran/tests/test_xdoc.py::TestDoctest::test_toolchain
+ # Tries to invoke pip
+ pythran/tests/test_distutils.py::TestDistutils::test_setup_build
+ pythran/tests/test_distutils.py::TestDistutils::test_setup_build2
+ )
+
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}