summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-29 16:29:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-29 16:56:05 +0200
commit37b66c9324a909ad4e7fc63c62fb58e5af99bbe6 (patch)
tree8ab53713eab5b411d6c770b4b3abc46b0df3914d /dev-python/qiskit-aer
parentdev-ruby/rack-test: drop 2.0.2 (diff)
downloadgentoo-37b66c9324a909ad4e7fc63c62fb58e5af99bbe6.tar.gz
gentoo-37b66c9324a909ad4e7fc63c62fb58e5af99bbe6.tar.bz2
gentoo-37b66c9324a909ad4e7fc63c62fb58e5af99bbe6.zip
dev-python/qiskit-aer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qiskit-aer')
-rw-r--r--dev-python/qiskit-aer/Manifest1
-rw-r--r--dev-python/qiskit-aer/qiskit-aer-0.12.0.ebuild121
-rw-r--r--dev-python/qiskit-aer/qiskit-aer-0.12.2.ebuild3
3 files changed, 2 insertions, 123 deletions
diff --git a/dev-python/qiskit-aer/Manifest b/dev-python/qiskit-aer/Manifest
index 7315cdfac6be..e6d81388c924 100644
--- a/dev-python/qiskit-aer/Manifest
+++ b/dev-python/qiskit-aer/Manifest
@@ -1,3 +1,2 @@
DIST qiskit-aer-0.11.2.gh.tar.gz 6707283 BLAKE2B ae32a469d23a31f202b9f970c59e9efb76c290243bce6179b0a58590d671f6dec0428245131e7cb2966b818dae9fbe7e7078a63fac107572e9e7d4a66e47a539 SHA512 48b28f6c54c898bb3984062ec772373e90899fd436c8e00f0c4abd57b6b98ea6c647283445fe551bd516483b66d25c9861ef519f01a0d1ddc6b3ddbce07bc56a
-DIST qiskit-aer-0.12.0.gh.tar.gz 6730571 BLAKE2B 8d14012ffb0e12f32dc954dfa883bc43be6ac7aa4e01597d6abb11c22d7f39e9b419ab78db0c613d951555590498e1f0a5dbc7bb7047d2a8e71ae9a6216c79ab SHA512 4e594b56df671284492146c005de82ac184adf1b96acaf7fffea4b074cd0dc724445c0a10911a985a5e226960179926c94c21dae8edf7e615267b31d53c572e2
DIST qiskit-aer-0.12.2.gh.tar.gz 6979559 BLAKE2B c7f12c9b8f53a9031844e123b8ef6d723e0099be028c5cfba03143fb8b3c7269768ade99d3ef3b4b82c0b36756bf8e82971a3f70c0f5735891eb77a78a6d9512 SHA512 2a9ed6777e5e4d60a393d5a1b21b44ea3fa90fb791aeafda8bbb4ca8b55c7e8161cd5a275fd14bf968a22537cede099dbd419d1a3c5edebe85fdb82501c4de90
diff --git a/dev-python/qiskit-aer/qiskit-aer-0.12.0.ebuild b/dev-python/qiskit-aer/qiskit-aer-0.12.0.ebuild
deleted file mode 100644
index ec1410b313db..000000000000
--- a/dev-python/qiskit-aer/qiskit-aer-0.12.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="High performance simulator for quantum circuits that includes noise models"
-HOMEPAGE="
- https://github.com/Qiskit/qiskit-aer/
- https://pypi.org/project/qiskit-aer/
-"
-SRC_URI="
- https://github.com/Qiskit/qiskit-aer/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests fail: https://github.com/Qiskit/qiskit-aer/issues/1742
-#KEYWORDS="~amd64"
-
-# The reference implementation of BLAS/CBLAS is not compatible with qiskit-aer right now,
-# because importing library causes an error.
-# /usr/lib/python3.9/site-packages/qiskit/providers/aer/backends/controller_wrappers.cpython-39-x86_64-linux-gnu.so: undefined symbol: slamch_
-# Using sci-libs/openblas instead here,
-# with the option to switch between reference/openblas implementation runtime (eselect-ldso).
-DEPEND="
- >=dev-python/numpy-1.16.3[${PYTHON_USEDEP}]
- >=dev-cpp/nlohmann_json-3.1.1
- >=dev-libs/spdlog-1.9.2:=
- >=dev-cpp/muParserX-4.0.8
- virtual/cblas[eselect-ldso]
- sci-libs/openblas[eselect-ldso]
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/qiskit-terra-0.21.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-util/cmake-3.17
- >=dev-python/scikit-build-0.11.0[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/ddt[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # Remove cmake dependency from setup.py because of
- # invalid dependency description. We put this dependency check in BDEPEND.
- "${FILESDIR}"/${PN}-0.12.0-remove-cmake-dependency.patch
- "${FILESDIR}"/${PN}-0.12.0-wheel-dep.patch
-)
-
-distutils_enable_tests pytest
-
-check_openblas() {
- local libdir=$(get_libdir) me="openblas"
-
- # check blas
- local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
- if [[ ${current_blas} != "${me}" ]]; then
- eerror "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- eerror "To use qiskit-aer, you have to issue (as root):"
- eerror "\t eselect blas set ${libdir} ${me}"
- return 1
- fi
- return 0
-}
-
-pkg_setup() {
- if use test; then
- check_openblas
- if [[ $? -ne 0 ]]; then
- die "Set blas implementation to openblas using 'eselect blas set openblas'!"
- fi
- fi
-}
-
-python_prepare_all() {
- export DISABLE_CONAN="ON"
- export DISABLE_DEPENDENCY_INSTALL="ON"
- #export SKBUILD_CONFIGURE_OPTIONS=""
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- test/terra/states/test_aer_statevector.py::TestAerStatevector::test_drawings
- test/terra/states/test_aer_state.py::TestAerState::test_appply_diagonal
- test/terra/states/test_aer_state.py::TestAerState::test_appply_measure
- test/terra/states/test_aer_state.py::TestAerState::test_appply_reset
-
- # TODO: GLIBCXX_ASSERTIONS, bug #897758
- test/terra/backends/aer_simulator/test_algorithms.py::TestAlgorithms::test_extended_stabilizer_sparse_output_probs
- test/terra/backends/aer_simulator/test_options.py::TestOptions::test_mps_options
- test/terra/backends/aer_simulator/test_fusion.py::TestGateFusion::test_parallel_fusion_diagonal
- )
-
- # From tox.ini/tests.yml in CI
- # Needed to suppress a warning in jupyter-core 5.x by eagerly migrating to
- # a new internal interface that will be the default in jupyter-core 6.x.
- # This variable should become redundant on release of jupyter-core 6.
- local -x JUPYTER_PLATFORM_DIRS=1
-
- rm -rf qiskit_aer || die
- epytest -n "$(makeopts_jobs)" -s
-}
-
-pkg_postinst() {
- check_openblas
-}
diff --git a/dev-python/qiskit-aer/qiskit-aer-0.12.2.ebuild b/dev-python/qiskit-aer/qiskit-aer-0.12.2.ebuild
index a71df28d8888..8087bdb6856a 100644
--- a/dev-python/qiskit-aer/qiskit-aer-0.12.2.ebuild
+++ b/dev-python/qiskit-aer/qiskit-aer-0.12.2.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
@@ -86,7 +87,7 @@ pkg_setup() {
python_prepare_all() {
export DISABLE_CONAN="ON"
export DISABLE_DEPENDENCY_INSTALL="ON"
- #export SKBUILD_CONFIGURE_OPTIONS=""
+ export SKBUILD_CONFIGURE_OPTIONS="-DTEST_JSON=1"
distutils-r1_python_prepare_all
}