summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-02 20:39:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-02 21:54:20 +0300
commit2c26ff87954e1a66b053c5d90faa771c8a1b2fa3 (patch)
tree5cd0317f466fb382151b697acbb1f416b4bbcda6 /dev-python/rich
parentsys-libs/libbacktrace: Version bump based on work by Matt Whitlock (diff)
downloadgentoo-2c26ff87954e1a66b053c5d90faa771c8a1b2fa3.tar.gz
gentoo-2c26ff87954e1a66b053c5d90faa771c8a1b2fa3.tar.bz2
gentoo-2c26ff87954e1a66b053c5d90faa771c8a1b2fa3.zip
dev-python/rich: add 12.6.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-12.6.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 6af9ef5c63ec..de140f67e215 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-12.5.1.gh.tar.gz 15034345 BLAKE2B 0ff73986d46c70ad6c959bdad2a28e25404bc7f50567f2d559213dfc5341a58b3e3f5e20907275b507f12c107e5d2e947434949ffb7887abad86d4df8cf3ba72 SHA512 41b4328211b825319962056a56df66b86770f62556f84c6c9ad276ae919ec352cda58ecae4535cdca8461913b6be4b8f30d81e0a91cb9a2944a890206215f11f
+DIST rich-12.6.0.gh.tar.gz 15056457 BLAKE2B 58367ef0acb61d68931ea0394ea458e29b3bb59726c6b95d4b179553183c5cef2766484e0d040203181aad927add70198fb3483bfe6113e20851db141de3a867 SHA512 e05a0ad1d6b4f1e4f7e5e3d09c70d5892a618707ae0952e34274c5ffb18a833fe85a4ac15024cc34915515b63059c02f0df32a6c97cbe91e9ac96928c7134fb0
diff --git a/dev-python/rich/rich-12.6.0.ebuild b/dev-python/rich/rich-12.6.0.ebuild
new file mode 100644
index 000000000000..9ba4c176535d
--- /dev/null
+++ b/dev-python/rich/rich-12.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # broken with >=dev-python/pygments-2.12.0
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # the usual deal: output changes that cause test mismatches
+ tests/test_inspect.py::test_inspect_text
+ tests/test_inspect.py::test_inspect_builtin_function
+ tests/test_inspect.py::test_inspect_integer_with_methods
+ tests/test_log.py::test_log
+ tests/test_pretty.py::test_attrs_broken
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}