summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 17:10:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 17:10:34 +0200
commit23317bd90047b06713fc1a81d9679cfe1fa7418d (patch)
tree881d24c55c08c4ff71f3fcd7f6eddb77ae072afa /dev-python/sabctools
parentRename dev-python/{sabyenc → sabctools} (diff)
downloadgentoo-23317bd90047b06713fc1a81d9679cfe1fa7418d.tar.gz
gentoo-23317bd90047b06713fc1a81d9679cfe1fa7418d.tar.bz2
gentoo-23317bd90047b06713fc1a81d9679cfe1fa7418d.zip
dev-python/sabctools: Bump to 7.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sabctools')
-rw-r--r--dev-python/sabctools/Manifest1
-rw-r--r--dev-python/sabctools/sabctools-7.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sabctools/Manifest b/dev-python/sabctools/Manifest
index b2038b017e6a..e99727f97b61 100644
--- a/dev-python/sabctools/Manifest
+++ b/dev-python/sabctools/Manifest
@@ -1 +1,2 @@
DIST sabctools-7.0.2.gh.tar.gz 8539819 BLAKE2B 38212656c745238f106fbc9334f6dccb02bb9e05153bc73a21a783a25a0c5a63cae2893a01fcceefe37e6f5f187fc6d762fcc632f1228410e951740c808e0e9e SHA512 05968a29afb7a041549bae9e9a4303160820da4cd10ea33ab4475fe48fd0b4cf46023c6254715161265f3e1bdf2b66ae7e62007789fbc288aa229d3a218a3df8
+DIST sabctools-7.1.0.gh.tar.gz 8539861 BLAKE2B d19f46dc9d92ebd59f74b74f21129c11d425e690d9b43278cc691c41a2f85bf307775969f6bc0716ac74cd4f630971caa0896ac7c6af129bb9c58383e5afdba3 SHA512 bba1c441111aafd8b028a34637d1f9b855b7d232545bc6e56f7cc650bc22a7ee6a1ad6258aa963ef338a061adb5cd9692e1d6ea215ca7bd9fa7bf06b90079e5b
diff --git a/dev-python/sabctools/sabctools-7.1.0.ebuild b/dev-python/sabctools/sabctools-7.1.0.ebuild
new file mode 100644
index 000000000000..a500ef55dcbb
--- /dev/null
+++ b/dev-python/sabctools/sabctools-7.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest