summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-11-23 05:56:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-11-23 05:56:13 +0000
commit07de1d1639bc66a9fb1318b65f44f751b7761ee2 (patch)
tree58487d0c8f5dabac82f564323d82913bb994fb08 /dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
parentsys-apps/syd: add 3.3.4, drop 3.3.2 (diff)
downloadgentoo-07de1d1639bc66a9fb1318b65f44f751b7761ee2.tar.gz
gentoo-07de1d1639bc66a9fb1318b65f44f751b7761ee2.tar.bz2
gentoo-07de1d1639bc66a9fb1318b65f44f751b7761ee2.zip
dev-python/sshtunnel: add 0.4.0
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.4.0.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.4.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild b/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
new file mode 100644
index 000000000000..ec966060b5be
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python SSH tunnels"
+HOMEPAGE="https://pypi.org/project/sshtunnel/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+RESTRICT="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"