summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-02 17:47:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-02 17:51:14 +0100
commit664329370a48b8419b5c840c1104efcb0dd347fd (patch)
tree3c134ab44cd776bbdecc8ddd83ee5660155e22b7 /dev-python/tqdm
parentdev-python/tqdm: Bump to 4.55.1 (diff)
downloadgentoo-664329370a48b8419b5c840c1104efcb0dd347fd.tar.gz
gentoo-664329370a48b8419b5c840c1104efcb0dd347fd.tar.bz2
gentoo-664329370a48b8419b5c840c1104efcb0dd347fd.zip
dev-python/tqdm: Remove unmaintained obsolete live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/tqdm-9999.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/tqdm/tqdm-9999.ebuild b/dev-python/tqdm/tqdm-9999.ebuild
deleted file mode 100644
index f8988f331138..000000000000
--- a/dev-python/tqdm/tqdm-9999.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/tqdm/tqdm"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~sparc ~x86"
-fi
-
-DESCRIPTION="Add a progress meter to your loops in a second"
-HOMEPAGE="https://github.com/tqdm/tqdm"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- sed -r \
- -e "s:'nose'(,[[:space:]]*|)::" \
- -e "s:'flake8'(,[[:space:]]*|)::" \
- -e "s:'coverage'(,[[:space:]]*|)::" \
- -i setup.py
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # tests_main.py requires the package to be installed
- distutils_install_for_testing
- # Skip unpredictable performance tests
- nosetests tqdm -v --ignore 'tests_perf.py' \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
- doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
- rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
- distutils-r1_python_install --skip-build
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}