summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 22:50:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 23:26:46 +0200
commit68d278b1c66be066c7c6787f13e068d59dafa1bd (patch)
treee258dac65d76ec8ad26926c875cdd0a0d251cf21 /dev-python/xmlschema
parentdev-python/hcloud-python: Add python@ as co-maint. (diff)
downloadgentoo-68d278b1c66be066c7c6787f13e068d59dafa1bd.tar.gz
gentoo-68d278b1c66be066c7c6787f13e068d59dafa1bd.tar.bz2
gentoo-68d278b1c66be066c7c6787f13e068d59dafa1bd.zip
dev-python/xmlschema: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.6.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index e625809ca4dd..7ba0eeb396be 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-1.5.3.tar.gz 350684 BLAKE2B 5dfcd2e00339caa834195729cce1604d17e5aa4705150649e22bebe3dc7b3ac6ace5dccbc7b6313c5cadb5ca29992853191afff2f76f05d18c10294131a904cf SHA512 3d86dc407d3181bf5c34b2d6aead9995eca1b7210b39ce3cb95c5655fa0cac0bbcc9f15c6ac016aca69a23f19befbe0525d6f13644b68fde348dcd0fd03bfa73
+DIST xmlschema-1.6.0.tar.gz 362175 BLAKE2B a9ff2807e3371ca81af3f0febf555c3fb5cea0b3623925e5b9c5f7b48df8e7c7118f3654930dd13b785ab1f1816d43df08316ddaeca2df983dc3f611ebacad10 SHA512 d72c85307b2b22bb59ed3331a1fbb8fd4ce58e69fed1762e37b89fba6c2f704753123ae34bb6155bc60d287461e426eff48b2b6a04899f067f0f235129320099
diff --git a/dev-python/xmlschema/xmlschema-1.6.0.ebuild b/dev-python/xmlschema/xmlschema-1.6.0.ebuild
new file mode 100644
index 000000000000..5bb53aff4381
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.2.1[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}