summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 15:43:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 16:19:02 +0100
commit82e72d38219f6004364de7eaa043277ab0d21c2c (patch)
tree93d22474bf30dc25431dd0f64c7183510f098f67 /dev-python
parentdev-python/jupyter-client: Bump to 8.6.0 (diff)
downloadgentoo-82e72d38219f6004364de7eaa043277ab0d21c2c.tar.gz
gentoo-82e72d38219f6004364de7eaa043277ab0d21c2c.tar.bz2
gentoo-82e72d38219f6004364de7eaa043277ab0d21c2c.zip
dev-python/jupyter-events: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter-events/Manifest1
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jupyter-events/Manifest b/dev-python/jupyter-events/Manifest
index 619bd4fbd503..0ee3296c4755 100644
--- a/dev-python/jupyter-events/Manifest
+++ b/dev-python/jupyter-events/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_events-0.7.0.tar.gz 59717 BLAKE2B 80ff725f4a39495ef7bf447d3bf1dcd3d7c28875c16f082788d948efec8498f01d74bb59b771537e22be7c57c0e75dd9bba70e7802262d676b531318a18d93cb SHA512 ce5ddabc4f540bfa6808319b783ad8ffcb908bc26e7435293bda4ed88221126284dfda1aafc165c8a13bdd6056ec0477915b008f4788bc19730718d4a9e3f162
DIST jupyter_events-0.8.0.tar.gz 60373 BLAKE2B dc58ae9a561f7ffd81758b116d5cb93e6ee5d4bdc5ee3d067103aefbe66e01e1809e7194617f541abec84efdd81b4311024b2b50f863bad62127218eafdfbd31 SHA512 9b43e1f0f5e390455fac52971f41695a7c0d853ac4a84493e31efdd61a183e4a41c7824f963b89ee369cac8945d6258857b864315bbafe8be15145eee7075afd
+DIST jupyter_events-0.9.0.tar.gz 60502 BLAKE2B faf2c7b1b1403c809e98673dc2600750d5c18ff2578b7f1f6f569fa5ac5e955384eda69f0d281a8aa504a1bbeba639931b0fc01bd117b1621fdeb64d4c6881bb SHA512 7b70edd79b80a3d73f0fedd21f0dba8060cb190b0dc8a6d7d9d11fdfd5b219c7a2f54438f0888c062e00b7def37fa0d7cfb0213bfa8d93737a83802079e4b103
diff --git a/dev-python/jupyter-events/jupyter-events-0.9.0.ebuild b/dev-python/jupyter-events/jupyter-events-0.9.0.ebuild
new file mode 100644
index 000000000000..ac264b526208
--- /dev/null
+++ b/dev-python/jupyter-events/jupyter-events-0.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# jsonschema[format-nongpl] deps are always on in our ebuild
+RDEPEND="
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ dev-python/referencing[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest