summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-10-13 08:34:15 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-10-13 10:37:42 +0100
commit7f09b76558b7f1456a4a9ce5df04f3567c808a15 (patch)
tree7b3af5a565b83ba4b791c3e1f676c302e9b2453e /games-engines
parentgames-engines/fheroes2: drop 1.1.1 (diff)
downloadgentoo-7f09b76558b7f1456a4a9ce5df04f3567c808a15.tar.gz
gentoo-7f09b76558b7f1456a4a9ce5df04f3567c808a15.tar.bz2
gentoo-7f09b76558b7f1456a4a9ce5df04f3567c808a15.zip
games-engines/fheroes2: stop depending on python directly
Closes: https://bugs.gentoo.org/941434 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/fheroes2/fheroes2-1.1.2-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/games-engines/fheroes2/fheroes2-1.1.2-r1.ebuild b/games-engines/fheroes2/fheroes2-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..20ce7e8e3312
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.1.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_prepare() {
+ sed -i -e "s/python3/${EPYTHON}/" script/homm2/extract_homm2_resources.sh || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}