summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas PARLANT <nicolas.parlant@parhuet.fr>2025-01-13 13:08:52 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-16 20:40:26 +0100
commit2f4972b8733532c43c7cb05e9395f6141185ca5e (patch)
treef5613652c8c2f934b7519ba0ae00568e33ca947b /media-gfx
parentmedia-video/mkvtoolnix: Stabilize 88.0 amd64, #947265 (diff)
downloadgentoo-2f4972b8733532c43c7cb05e9395f6141185ca5e.tar.gz
gentoo-2f4972b8733532c43c7cb05e9395f6141185ca5e.tar.bz2
gentoo-2f4972b8733532c43c7cb05e9395f6141185ca5e.zip
media-gfx/phototonic: add 9999 - qt6
Initial project is unmaintained, a fork continues : https://github.com/oferkv/phototonic/commit/6d3f8f6f2a1fed57ca856e4e2a3e49ab18bc6e39 basic port to qt6 just works no release for now : see issues/3 Signed-off-by: Nicolas PARLANT <nicolas.parlant@parhuet.fr> Closes: https://github.com/gentoo/gentoo/pull/40138 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/phototonic/metadata.xml2
-rw-r--r--media-gfx/phototonic/phototonic-9999.ebuild37
2 files changed, 38 insertions, 1 deletions
diff --git a/media-gfx/phototonic/metadata.xml b/media-gfx/phototonic/metadata.xml
index f05b374d7585..a40d8d29c5ef 100644
--- a/media-gfx/phototonic/metadata.xml
+++ b/media-gfx/phototonic/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
- <remote-id type="github">oferkv/phototonic</remote-id>
+ <remote-id type="github">luebking/phototonic</remote-id>
</upstream>
</pkgmetadata>
diff --git a/media-gfx/phototonic/phototonic-9999.ebuild b/media-gfx/phototonic/phototonic-9999.ebuild
new file mode 100644
index 000000000000..00dd9c738ecc
--- /dev/null
+++ b/media-gfx/phototonic/phototonic-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Image viewer and organizer"
+HOMEPAGE="https://github.com/luebking/phototonic"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/luebking/phototonic.git"
+else
+ SRC_URI="https://github.com/luebking/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="svg tiff"
+
+RDEPEND="
+ dev-qt/qtbase:6[gui,opengl,widgets]
+ media-gfx/exiv2:=
+ svg? ( dev-qt/qtsvg:6 )
+ tiff? ( dev-qt/qtimageformats:6 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake6
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}