summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-10 21:11:50 -0300
committerPacho Ramos <pacho@gentoo.org>2024-09-29 20:03:00 +0200
commit05485e611d0c3d03a36bc0b3751d8335feecddad (patch)
tree97d45cbaad19ea9c79f445ff0e65188b9624f112 /media-libs/gexiv2
parentnet-libs/gupnp: Bump to 1.6.7 (diff)
downloadgentoo-05485e611d0c3d03a36bc0b3751d8335feecddad.tar.gz
gentoo-05485e611d0c3d03a36bc0b3751d8335feecddad.tar.bz2
gentoo-05485e611d0c3d03a36bc0b3751d8335feecddad.zip
media-libs/gexiv2: Bump to 0.14.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38088 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/Manifest1
-rw-r--r--media-libs/gexiv2/gexiv2-0.14.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index 00a2e8a8f04d..5ef69e5d5a0f 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1 +1,2 @@
DIST gexiv2-0.14.2.tar.xz 389488 BLAKE2B 37e79b1dd4c4324d4d7e2ef709b803a11aff4fbbe50ce5f0a4ff3f0053c77e251150297c1d0b42399c08f67bb669ee88b1e53ea1e853689480b3491ab45bc3e5 SHA512 16536be5180d5f13f549a68f5b701343a1246eca99083e43e6fc700b151614ea80696f931fcbc721b05955173e3206819b593e5b0fcd8ad4fd7d3b287d9c1441
+DIST gexiv2-0.14.3.tar.xz 389976 BLAKE2B 157e551ff74ab8158343b993b5eccfb282f9acc851fb43c60886b199b0cc309958efd0440304b49d69ef6cd8969755fd8a6a31c9733b15d16a21e8f90cdff223 SHA512 24c97fa09b9ee32cb98da4637ea78eb72ae7e2d1792f9ebb31d63e305b3e0e1f6935b8647589c76c39ba631a15c1d8d2f3879c7dff81433786e9533b6348b6a0
diff --git a/media-libs/gexiv2/gexiv2-0.14.3.ebuild b/media-libs/gexiv2/gexiv2-0.14.3.ebuild
new file mode 100644
index 000000000000..5a52d62a46fb
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.14.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome.org meson python-r1 vala
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+IUSE="gtk-doc +introspection python test +vala"
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=media-gfx/exiv2-0.26:=
+ >=dev-libs/glib-2.46.0:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ test? ( media-gfx/exiv2[xmp] )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ -Dtools=false # requires vala, freshly promoted tool that some other distros don't ship yet either
+ # Prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules)
+ -Dpython3=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ python_foreach_impl python_optimize
+ fi
+}