summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2024-09-27 10:00:11 -0400
committerRick Farina <zerochaos@gentoo.org>2024-09-27 10:00:21 -0400
commit6c6ab1f71f11d2d692fa3bfb610a64a37f729895 (patch)
tree37f89feefc4e6c72ccb279df34b2d3a8d48520a6 /net-analyzer/yersinia/yersinia-0.8.2_p20221119.ebuild
parentwww-apps/prowlarr-bin: drop 1.24.2.4749 (diff)
downloadgentoo-6c6ab1f71f11d2d692fa3bfb610a64a37f729895.tar.gz
gentoo-6c6ab1f71f11d2d692fa3bfb610a64a37f729895.tar.bz2
gentoo-6c6ab1f71f11d2d692fa3bfb610a64a37f729895.zip
net-analyzer/yersinia: add 0.8.2_p20221119, drop 0.8.2-r2
current 0.8.2-r2 USE=gtk didn't appear to function correctly. I fixed the deps to be a bit more explicit but that didn't fix it. Upgrading to current git snapshot fixed the issue so I am removing the non-working version and replacing it with a working version in one commit. Additionally removing unneeded patches, thanks to Sam for upstreaming them. Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-analyzer/yersinia/yersinia-0.8.2_p20221119.ebuild')
-rw-r--r--net-analyzer/yersinia/yersinia-0.8.2_p20221119.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-analyzer/yersinia/yersinia-0.8.2_p20221119.ebuild b/net-analyzer/yersinia/yersinia-0.8.2_p20221119.ebuild
new file mode 100644
index 000000000000..3e07f8adbe01
--- /dev/null
+++ b/net-analyzer/yersinia/yersinia-0.8.2_p20221119.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A framework for layer 2 attacks"
+HOMEPAGE="http://www.yersinia.net/"
+#SRC_URI="https://github.com/tomac/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="867b309eced9e02b63412855440cd4f5f7727431"
+SRC_URI="https://github.com/tomac/yersinia/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk ncurses"
+
+RDEPEND="
+ >=net-libs/libnet-1.1.2:1.1
+ >=net-libs/libpcap-0.9.4
+ ncurses? ( >=sys-libs/ncurses-5.5:= )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ =x11-libs/gtk+-2*:2
+ x11-libs/pango
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog FAQ README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-no-ncurses.patch
+ "${FILESDIR}"/${PN}-0.7.3-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use gtk; then
+ # bug #514802
+ sed -i -e '/AM_GLIB_GNU_GETTEXT/d' configure.in || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+
+ econf \
+ --enable-admin \
+ --with-pcap-includes=/usr/include \
+ $(use_with ncurses) \
+ $(use_enable gtk)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}