summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-24 06:21:33 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-24 06:21:33 -0400
commitfa2dc89887d5a006adcc83e64e63d7140f8eecaa (patch)
tree837af77e755970d708cc72d71a08cf5f0918f51c /net-fs/btfs/btfs-2.16.ebuild
parentwww-apps/dokuwiki: Add releases 20160626e and 20170219e - security bump to ad... (diff)
downloadgentoo-fa2dc89887d5a006adcc83e64e63d7140f8eecaa.tar.gz
gentoo-fa2dc89887d5a006adcc83e64e63d7140f8eecaa.tar.bz2
gentoo-fa2dc89887d5a006adcc83e64e63d7140f8eecaa.zip
net-fs/btfs: version bump to 2.16
Diffstat (limited to 'net-fs/btfs/btfs-2.16.ebuild')
-rw-r--r--net-fs/btfs/btfs-2.16.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-fs/btfs/btfs-2.16.ebuild b/net-fs/btfs/btfs-2.16.ebuild
new file mode 100644
index 000000000000..62a37b110eb3
--- /dev/null
+++ b/net-fs/btfs/btfs-2.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools python-r1
+
+DESCRIPTION="a bittorrent filesystem based on FUSE"
+HOMEPAGE="https://github.com/johang/btfs"
+SRC_URI="https://github.com/johang/btfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND=">=sys-fs/fuse-2.8.0
+ >=net-misc/curl-7.22.0
+ dev-libs/boost:=
+ >=net-libs/libtorrent-rasterbar-0.16.0:="
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # don't install btplay via make
+ sed -i '/^SUBDIRS =/s/scripts//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript scripts/btplay
+}