summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-08-09 12:23:56 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-08-09 12:24:05 +0300
commit4d7d135fa009ff950c343c26b56c7be68474c4f7 (patch)
tree7bcb7c2d9ab521892cc2e9fcf4a003e4aa694b09 /net-libs
parentapp-misc/elasticsearch: Bump, fix #585824 (diff)
downloadgentoo-4d7d135fa009ff950c343c26b56c7be68474c4f7.tar.gz
gentoo-4d7d135fa009ff950c343c26b56c7be68474c4f7.tar.bz2
gentoo-4d7d135fa009ff950c343c26b56c7be68474c4f7.zip
net-libs/gnutls: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/Manifest1
-rw-r--r--net-libs/gnutls/gnutls-3.5.3.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/net-libs/gnutls/Manifest b/net-libs/gnutls/Manifest
index 46eecfbff610..c2c1291993c0 100644
--- a/net-libs/gnutls/Manifest
+++ b/net-libs/gnutls/Manifest
@@ -6,3 +6,4 @@ DIST gnutls-3.4.14.tar.xz 6673148 SHA256 35deddf2779b76ac11057de38bf380b8066c05d
DIST gnutls-3.5.0.tar.xz 6716848 SHA256 fc6b3b544d411e6ca54dd6167541770559070ea15e6868946cf56a621d58ae25 SHA512 0b53b8084972e9b47e71c47ca9a42d0413c781641f4da640a1016aa0c1a736863a57eadbd9bb81248d3fdf723796edbb1424b14f9846b2300ad7650925f2ac27 WHIRLPOOL 0f1b3e07f94f101b004ecb1024424a10826d32bab0168076e412cd8d3881af8d77b440395b1811a910188d950ed71a2eb13e87dae029ee4c8c461a3d71077ba3
DIST gnutls-3.5.1.tar.xz 6799264 SHA256 bc4a0f80a627c3aca6e7ea59d30e50cda118c61e0e3fab367ff1451d6ec8bdbd SHA512 d59d0a7624a2783645d217a2f6955e8a5e67eea4a9bc682b101cf939f7b623f046b381bc12ae0bae08c17031e4bd178e615afbe2cdde3914433b8d829c353e14 WHIRLPOOL 1ce587c664896115a0b8f4d8bfadb562738b85db15dc592d049c89a10c1386ec2ec73f7bc94a7291188e590cd862419a15dac8ac37670629998231216a2450ce
DIST gnutls-3.5.2.tar.xz 6829132 SHA256 2b45e95cbfd21d76da6fc4846794d8845dbc66bb03c6aa1428881586cfbe8582 SHA512 c9438a5c20316e41bbcaaa5e88c3fcbb750f336d8ac8ea196e0d7840fb4ccc64b00cda70ea81afbe8ee9fa790fbfb3ed3c84689378397adaf97031fbc2f260d0 WHIRLPOOL b27d6c72eea6c135fde946dd5db64d3ba23864aa48e96c2d9271dd845878c9947f70d2f78270396d5556dada95b84bb9fd7a884e697fb0dd6c4bd8a78152d3cb
+DIST gnutls-3.5.3.tar.xz 6895068 SHA256 92c4bc999a10a1b95299ebefaeea8333f19d8a98d957a35b5eae74881bdb1fef SHA512 d53d8067628ce49e5bb0dbbd76761a27f585b0a38356c0d8524db6cf96542f54a7f8a87c5772335c1ca1ceec1e111e11c54636bb24ca2ac014c367b96c9e3969 WHIRLPOOL fc0b7a744c6c08a48c43a2e95781ec7139600b45b12f8352db01824468f301ab56f2adfec6f7a4806247fe33eadaa234ad541a27c75d8689c2817a0f5967aa05
diff --git a/net-libs/gnutls/gnutls-3.5.3.ebuild b/net-libs/gnutls/gnutls-3.5.3.ebuild
new file mode 100644
index 000000000000..efe688485ad4
--- /dev/null
+++ b/net-libs/gnutls/gnutls-3.5.3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools libtool eutils multilib-minimal versionator
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="mirror://gnupg/gnutls/v$(get_version_component_range 1-2)/${P}.tar.xz"
+
+# LGPL-3 for libgnutls library and GPL-3 for libgnutls-extra library.
+# soon to be relicensed as LGPL-2.1 unless heartbeat extension enabled.
+LICENSE="GPL-3 LGPL-3"
+SLOT="0/30" # libgnutls.so number
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE_LINGUAS=" en cs de fi fr it ms nl pl sv uk vi zh_CN"
+IUSE="+cxx dane doc examples guile nls +openssl pkcs11 static-libs test +tools zlib ${IUSE_LINGUAS// / linguas_}"
+# heartbeat support is not disabled until re-licensing happens fullyf
+
+# NOTICE: sys-devel/autogen is required at runtime as we
+# use system libopts
+RDEPEND=">=dev-libs/libtasn1-4.3[${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-3.1:=[gmp,${MULTILIB_USEDEP}]
+ >=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]
+ tools? ( sys-devel/autogen )
+ dane? ( >=net-dns/unbound-1.4.20[${MULTILIB_USEDEP}] )
+ guile? ( >=dev-scheme/guile-1.8:*[networking] )
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ pkcs11? ( >=app-crypt/p11-kit-0.23.1[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.11.6
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ doc? (
+ sys-apps/texinfo
+ dev-util/gtk-doc
+ )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+pkg_setup() {
+ # bug#520818
+ export TZ=UTC
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
+ doc/Makefile.am || die
+
+ # force regeneration of autogen-ed files
+ local file
+ for file in $(grep -l AutoGen-ed src/*.c) ; do
+ rm src/$(basename ${file} .c).{c,h} || die
+ done
+
+ # force regeneration of makeinfo files
+ # have no idea why on some system these files are not
+ # accepted as-is, see bug#520818
+ for file in $(grep -l "produced by makeinfo" doc/*.info) ; do
+ rm "${file}" || die
+ done
+
+ eautoreconf
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+
+ # bug 497472
+ use cxx || epunt_cxx
+}
+
+multilib_src_configure() {
+ LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
+
+ # TPM needs to be tested before being enabled
+ # hardware-accell is disabled on OSX because the asm files force
+ # GNU-stack (as doesn't support that) and when that's removed ld
+ # complains about duplicate symbols
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-valgrind-tests \
+ --without-included-libtasn1 \
+ --enable-heartbeat-support \
+ $(use_enable cxx) \
+ $(use_enable dane libdane) \
+ $(multilib_native_enable manpages) \
+ $(multilib_native_use_enable tools) \
+ $(multilib_native_use_enable doc) \
+ $(multilib_native_use_enable doc gtk-doc) \
+ $(multilib_native_use_enable guile) \
+ $(multilib_native_use_enable test tests) \
+ $(use_enable nls) \
+ $(use_enable openssl openssl-compatibility) \
+ $(use_enable static-libs static) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_with zlib) \
+ --without-tpm \
+ --with-unbound-root-key-file=/etc/dnssec/root-anchors.txt \
+ $([[ ${CHOST} == *-darwin* ]] && echo --disable-hardware-acceleration)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ dodoc doc/certtool.cfg
+
+ if use doc; then
+ dohtml doc/gnutls.html
+ else
+ rm -fr "${ED}/usr/share/doc/${PF}/html"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}