summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-09-08 23:58:21 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-09-09 21:04:12 -0400
commit9709c3e5dd9a4fe6d398f8c1cfbf48b649efd440 (patch)
tree465e9c56553adba9c074f7ba06c7acabd08546d2 /sci-mathematics
parentsci-mathematics/twelf: update HOMEPAGE for https (diff)
downloadgentoo-9709c3e5dd9a4fe6d398f8c1cfbf48b649efd440.tar.gz
gentoo-9709c3e5dd9a4fe6d398f8c1cfbf48b649efd440.tar.bz2
gentoo-9709c3e5dd9a4fe6d398f8c1cfbf48b649efd440.zip
sci-mathematics/twelf: mark as LTO-unsafe
Per the contributing guideline: > Twelf, the software, is not under active development, and changes to > the code of Twelf are unlikely to be accepted unless you’re working with > Twelf’s original authors, Frank Pfenning and Carsten Schürmann. Getting this fixed is unlikely to happen, so all that's left is filtering. Closes: https://bugs.gentoo.org/863266 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/twelf/twelf-1.7.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-mathematics/twelf/twelf-1.7.1-r2.ebuild b/sci-mathematics/twelf/twelf-1.7.1-r2.ebuild
index 9e6c45a37143..1fc16b00baa4 100644
--- a/sci-mathematics/twelf/twelf-1.7.1-r2.ebuild
+++ b/sci-mathematics/twelf/twelf-1.7.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI="8"
-inherit elisp-common
+inherit elisp-common flag-o-matic
MY_PN="${PN}-src"
MY_P="${MY_PN}-${PV}"
@@ -59,6 +59,12 @@ src_prepare() {
}
src_compile() {
+ # relocation R_X86_64_32 against hidden symbol `globalCPointer' can not be used when making a PIE object
+ # https://bugs.gentoo.org/863266
+ #
+ # The software is unmaintained and disables bug reports.
+ filter-lto
+
emake mlton CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} -fno-PIE"
if use emacs ; then
pushd "${S}/emacs" || die "Could change directory to emacs"