summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-02-28 11:40:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-02-28 11:40:08 +0000
commita4fddb80917ed3cdc011f25c874d8262d159ec84 (patch)
tree110e4e5fa367be1f3d9ba6bb00550c2c0a84a98a /sys-cluster/ucx
parentsys-cluster/openmpi: Bump (diff)
downloadgentoo-a4fddb80917ed3cdc011f25c874d8262d159ec84.tar.gz
gentoo-a4fddb80917ed3cdc011f25c874d8262d159ec84.tar.bz2
gentoo-a4fddb80917ed3cdc011f25c874d8262d159ec84.zip
sys-cluster/ucx: Bump
Fixes #725756 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sys-cluster/ucx')
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/ucx-1.9.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index 8c6528f41370..6fe2cc8d421a 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1,3 +1,4 @@
DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
DIST ucx-1.3.0.tar.gz 1707317 BLAKE2B 740ab240663a26fde8abe631416dae6233febf3c587ba6bb7b27a9cb0aa041540ce71e106bb3c5618a719de66d479055961908b67125df61a4c7696999c0affb SHA512 0a2e32985e0225fc4ad15dbb1c422dba1d5552638e7329d67572924502e61e1a481ce30cde5ccc83c663fb4ec643df83efc08aed164dfbce6cf38d66a16b3e42
DIST ucx-1.5.2.tar.gz 1844416 BLAKE2B 2e0296e34d8116a79c545fb3371dda1746517a18cc75f94da5d1f9420c7a74752839d5a3a07a61a2e91021baa87a26d02ab24554316351db9ba76721a18a5244 SHA512 7f11014eb26df342fc8f0914d323f08f4c19ea21e98e18f0a4ec18b7004299687f91daa8ee654ecee716ece6d4d6de5c9714c548768b1d44551b6be6195e2e9b
+DIST ucx-1.9.0.tar.gz 2467338 BLAKE2B 4d2d18c530f99a56baeb1dec88a7dba813970d3f501eb08f637dc7cefcfe5e564bc121e50c1842ea94e927a0fd657847c571241e3dd9601cdde207729d32d721 SHA512 2e8507e9cbba9ea445efdf8be5b5128dfc76cce30111805e9f7a5618bbbbb77d2bb449b6ad5e415f086b3156b63128306671d3a906583248cde720edb4241c67
diff --git a/sys-cluster/ucx/ucx-1.9.0.ebuild b/sys-cluster/ucx/ucx-1.9.0.ebuild
new file mode 100644
index 000000000000..65a9b0241cf7
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}