summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2024-10-17 10:36:48 +0800
committerBenda Xu <heroxbd@gentoo.org>2024-10-18 21:38:28 +0800
commitd091eed7f221f91edc00370b605d896eaa02e6b4 (patch)
tree990cd208f4d123bb828eec7bb112ed05a1c87452 /sys-cluster
parentsys-cluster/slurm: drop bashism in the initd script. (diff)
downloadgentoo-d091eed7f221f91edc00370b605d896eaa02e6b4.tar.gz
gentoo-d091eed7f221f91edc00370b605d896eaa02e6b4.tar.bz2
gentoo-d091eed7f221f91edc00370b605d896eaa02e6b4.zip
sys-cluster/slurm: all econf arguments into array.
Drop unnecessary htmldir hack. Closes: https://github.com/gentoo/gentoo/pull/38928 Suggested-by: Sam James <sam@gentoo.org> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/slurm/slurm-22.05.11.ebuild36
-rw-r--r--sys-cluster/slurm/slurm-24.05.3.ebuild36
2 files changed, 30 insertions, 42 deletions
diff --git a/sys-cluster/slurm/slurm-22.05.11.ebuild b/sys-cluster/slurm/slurm-22.05.11.ebuild
index dedeb5773dae..e074bd8ddc39 100644
--- a/sys-cluster/slurm/slurm-22.05.11.ebuild
+++ b/sys-cluster/slurm/slurm-22.05.11.ebuild
@@ -139,31 +139,25 @@ src_configure() {
--sysconfdir="${EPREFIX}/etc/${PN}"
--with-hwloc="${EPREFIX}/usr"
--htmldir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable debug)
+ $(use_enable lua)
+ $(use_enable pam)
+ $(use_enable X x11)
+ $(use_with munge)
+ $(use_with json)
+ $(use_with hdf5)
+ $(use_with nvml)
+ $(use_with ofed)
+ $(use_with ucx)
+ $(use_with yaml)
+ $(use_enable static-libs static)
+ $(use_enable slurmrestd)
+ $(use_enable multiple-slurmd)
)
use pam && myconf+=( --with-pam_dir=$(getpam_mod_dir) )
use mysql || myconf+=( --without-mysql_config )
- econf "${myconf[@]}" \
- $(use_enable debug) \
- $(use_enable lua) \
- $(use_enable pam) \
- $(use_enable X x11) \
- $(use_with munge) \
- $(use_with json) \
- $(use_with hdf5) \
- $(use_with nvml) \
- $(use_with ofed) \
- $(use_with ucx) \
- $(use_with yaml) \
- $(use_enable static-libs static) \
- $(use_enable slurmrestd) \
- $(use_enable multiple-slurmd)
+ econf "${myconf[@]}"
- # --htmldir does not seems to propagate... Documentations are installed
- # in /usr/share/doc/slurm-2.3.0/html
- # instead of /usr/share/doc/slurm-2.3.0.2/html
- sed \
- -e "s|htmldir = .*/html|htmldir = \${prefix}/share/doc/slurm-${PVR}/html|g" \
- -i doc/html/Makefile || die
if use perl ; then
# small hack to make it compile
mkdir -p "${S}/src/api/.libs" || die
diff --git a/sys-cluster/slurm/slurm-24.05.3.ebuild b/sys-cluster/slurm/slurm-24.05.3.ebuild
index f254ea437788..9c7134d77ef4 100644
--- a/sys-cluster/slurm/slurm-24.05.3.ebuild
+++ b/sys-cluster/slurm/slurm-24.05.3.ebuild
@@ -135,31 +135,25 @@ src_configure() {
--sysconfdir="${EPREFIX}/etc/${PN}"
--with-hwloc="${EPREFIX}/usr"
--htmldir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable debug)
+ $(use_with lua)
+ $(use_enable pam)
+ $(use_enable X x11)
+ $(use_with munge)
+ $(use_with json)
+ $(use_with hdf5)
+ $(use_with nvml)
+ $(use_with ofed)
+ $(use_with ucx)
+ $(use_with yaml)
+ $(use_enable static-libs static)
+ $(use_enable slurmrestd)
+ $(use_enable multiple-slurmd)
)
use pam && myconf+=( --with-pam_dir=$(getpam_mod_dir) )
use mysql || myconf+=( --without-mysql_config )
- econf "${myconf[@]}" \
- $(use_enable debug) \
- $(use_with lua) \
- $(use_enable pam) \
- $(use_enable X x11) \
- $(use_with munge) \
- $(use_with json) \
- $(use_with hdf5) \
- $(use_with nvml) \
- $(use_with ofed) \
- $(use_with ucx) \
- $(use_with yaml) \
- $(use_enable static-libs static) \
- $(use_enable slurmrestd) \
- $(use_enable multiple-slurmd)
+ econf "${myconf[@]}"
- # --htmldir does not seems to propagate... Documentations are installed
- # in /usr/share/doc/slurm-2.3.0/html
- # instead of /usr/share/doc/slurm-2.3.0.2/html
- sed \
- -e "s|htmldir = .*/html|htmldir = \${prefix}/share/doc/slurm-${PVR}/html|g" \
- -i doc/html/Makefile || die
if use perl ; then
# small hack to make it compile
mkdir -p "${S}/src/api/.libs" || die