summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:12:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:13 +0100
commitc614d9691e23ef798e5f7ca78768803f9be57c53 (patch)
treec16b3ceeb65682e6489aabe2d31894e8f459f84f /sys-devel
parentMove {sys-libs → llvm-runtimes}/libcxxabi (diff)
downloadgentoo-c614d9691e23ef798e5f7ca78768803f9be57c53.tar.gz
gentoo-c614d9691e23ef798e5f7ca78768803f9be57c53.tar.bz2
gentoo-c614d9691e23ef798e5f7ca78768803f9be57c53.zip
Move {sys-libs → llvm-runtimes}/libcxx
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.7-r10.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r6.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r10.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r9.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-18.1.8-r3.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-19.1.4.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-19.1.5.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild2
-rw-r--r--sys-devel/clang-runtime/metadata.xml2
-rw-r--r--sys-devel/llvm/llvm-15.0.7-r7.ebuild2
-rw-r--r--sys-devel/llvm/llvm-16.0.6-r5.ebuild2
-rw-r--r--sys-devel/llvm/llvm-17.0.6-r3.ebuild2
-rw-r--r--sys-devel/llvm/llvm-18.1.8-r6.ebuild2
-rw-r--r--sys-devel/llvm/llvm-19.1.4.ebuild2
-rw-r--r--sys-devel/llvm/llvm-19.1.5.ebuild2
-rw-r--r--sys-devel/llvm/llvm-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/llvm/llvm-20.0.0_pre20241207.ebuild2
26 files changed, 26 insertions, 26 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild b/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
index 863210b432e1..928aee10456d 100644
--- a/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
index 3c2341b48f12..e09335f6e3e5 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
index 4b4afea86e18..5870b71335a8 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
index 406fb5e000ac..7af16d4ac75b 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild b/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
index d27470c98f00..ae1a72c52b76 100644
--- a/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
+++ b/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-19.1.4.ebuild b/sys-devel/clang-common/clang-common-19.1.4.ebuild
index 30192b7fa601..f33390a4b4f1 100644
--- a/sys-devel/clang-common/clang-common-19.1.4.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.4.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-19.1.5.ebuild b/sys-devel/clang-common/clang-common-19.1.5.ebuild
index 5f4044001548..7fc5e4131cd6 100644
--- a/sys-devel/clang-common/clang-common-19.1.5.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.5.ebuild
@@ -23,7 +23,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
index b3216cd5a275..2c15d06f582f 100644
--- a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
@@ -22,7 +22,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
index b3216cd5a275..2c15d06f582f 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
@@ -22,7 +22,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
+ default-libcxx? ( >=llvm-runtimes/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( >=sys-devel/lld-${PV} )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
index c80214039ada..48df40caecd9 100644
--- a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
@@ -21,6 +21,6 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
index c175cf8f6d82..1b7669fda077 100644
--- a/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
index c175cf8f6d82..1b7669fda077 100644
--- a/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild b/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
index b8e570778a41..c10d8fdc02c6 100644
--- a/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
index b8e570778a41..c10d8fdc02c6 100644
--- a/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
index 23682d8dbe5d..8fc82482b153 100644
--- a/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
index 5096eef10239..0b80525972dd 100644
--- a/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
@@ -20,7 +20,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? (
>=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
offload? (
diff --git a/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild b/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
index 5096eef10239..0b80525972dd 100644
--- a/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
@@ -20,7 +20,7 @@ RDEPEND="
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? (
>=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
offload? (
diff --git a/sys-devel/clang-runtime/metadata.xml b/sys-devel/clang-runtime/metadata.xml
index 1339c7657454..fbfaee66297b 100644
--- a/sys-devel/clang-runtime/metadata.xml
+++ b/sys-devel/clang-runtime/metadata.xml
@@ -6,7 +6,7 @@
</maintainer>
<use>
<flag name="compiler-rt">Install <pkg>sys-libs/compiler-rt</pkg> for -rtlib=compiler-rt</flag>
- <flag name="libcxx">Install <pkg>sys-libs/libcxx</pkg> for -stdlib=libc++</flag>
+ <flag name="libcxx">Install <pkg>llvm-runtimes/libcxx</pkg> for -stdlib=libc++</flag>
<flag name="offload">Install <pkg>llvm-runtimes/offload</pkg> for -fopenmp GPU offloading</flag>
<flag name="openmp">Install <pkg>llvm-runtimes/openmp</pkg> for -fopenmp support</flag>
<flag name="sanitize">Enable compiler-rt sanitizer (-fsanitize*) support</flag>
diff --git a/sys-devel/llvm/llvm-15.0.7-r7.ebuild b/sys-devel/llvm/llvm-15.0.7-r7.ebuild
index e00a340662de..7b265356edae 100644
--- a/sys-devel/llvm/llvm-15.0.7-r7.ebuild
+++ b/sys-devel/llvm/llvm-15.0.7-r7.ebuild
@@ -45,7 +45,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
>=sys-devel/binutils-apple-5.1
)
doc? ( $(python_gen_any_dep '
diff --git a/sys-devel/llvm/llvm-16.0.6-r5.ebuild b/sys-devel/llvm/llvm-16.0.6-r5.ebuild
index 75644db0c645..0189ed1d09af 100644
--- a/sys-devel/llvm/llvm-16.0.6-r5.ebuild
+++ b/sys-devel/llvm/llvm-16.0.6-r5.ebuild
@@ -46,7 +46,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
doc? ( $(python_gen_any_dep '
dev-python/recommonmark[${PYTHON_USEDEP}]
diff --git a/sys-devel/llvm/llvm-17.0.6-r3.ebuild b/sys-devel/llvm/llvm-17.0.6-r3.ebuild
index 7e5c03df252a..3897a6e8eca9 100644
--- a/sys-devel/llvm/llvm-17.0.6-r3.ebuild
+++ b/sys-devel/llvm/llvm-17.0.6-r3.ebuild
@@ -50,7 +50,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
doc? ( $(python_gen_any_dep '
dev-python/recommonmark[${PYTHON_USEDEP}]
diff --git a/sys-devel/llvm/llvm-18.1.8-r6.ebuild b/sys-devel/llvm/llvm-18.1.8-r6.ebuild
index 4fc7e91ec91d..2b7e38ff768f 100644
--- a/sys-devel/llvm/llvm-18.1.8-r6.ebuild
+++ b/sys-devel/llvm/llvm-18.1.8-r6.ebuild
@@ -49,7 +49,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
libffi? ( virtual/pkgconfig )
"
diff --git a/sys-devel/llvm/llvm-19.1.4.ebuild b/sys-devel/llvm/llvm-19.1.4.ebuild
index 4368fff5eae2..5114929072a0 100644
--- a/sys-devel/llvm/llvm-19.1.4.ebuild
+++ b/sys-devel/llvm/llvm-19.1.4.ebuild
@@ -48,7 +48,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
libffi? ( virtual/pkgconfig )
"
diff --git a/sys-devel/llvm/llvm-19.1.5.ebuild b/sys-devel/llvm/llvm-19.1.5.ebuild
index 64c63c9517cb..53638adc3195 100644
--- a/sys-devel/llvm/llvm-19.1.5.ebuild
+++ b/sys-devel/llvm/llvm-19.1.5.ebuild
@@ -48,7 +48,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
libffi? ( virtual/pkgconfig )
"
diff --git a/sys-devel/llvm/llvm-20.0.0.9999.ebuild b/sys-devel/llvm/llvm-20.0.0.9999.ebuild
index d01575f39051..3a3e8c174ace 100644
--- a/sys-devel/llvm/llvm-20.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-20.0.0.9999.ebuild
@@ -47,7 +47,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
libffi? ( virtual/pkgconfig )
"
diff --git a/sys-devel/llvm/llvm-20.0.0_pre20241207.ebuild b/sys-devel/llvm/llvm-20.0.0_pre20241207.ebuild
index d01575f39051..3a3e8c174ace 100644
--- a/sys-devel/llvm/llvm-20.0.0_pre20241207.ebuild
+++ b/sys-devel/llvm/llvm-20.0.0_pre20241207.ebuild
@@ -47,7 +47,7 @@ BDEPEND="
dev-lang/perl
sys-devel/gnuconfig
kernel_Darwin? (
- <sys-libs/libcxx-${LLVM_VERSION}.9999
+ <llvm-runtimes/libcxx-${LLVM_VERSION}.9999
)
libffi? ( virtual/pkgconfig )
"