summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/etcdctl/etcdctl-0.4.6.ebuild')
-rw-r--r--dev-db/etcdctl/etcdctl-0.4.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/etcdctl/etcdctl-0.4.6.ebuild b/dev-db/etcdctl/etcdctl-0.4.6.ebuild
new file mode 100644
index 000000000000..45973eade0d4
--- /dev/null
+++ b/dev-db/etcdctl/etcdctl-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KEYWORDS="~amd64"
+DESCRIPTION="A simple command line client for etcd"
+HOMEPAGE="https://github.com/coreos/etcdctl/"
+SRC_URI="https://github.com/coreos/etcdctl/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=dev-lang/go-1.2"
+RDEPEND=""
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+src_test() {
+ ./test || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ use examples && dodoc -r examples
+}