summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/unixODBC/unixODBC-2.3.1.ebuild')
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.3.1.ebuild b/dev-db/unixODBC/unixODBC-2.3.1.ebuild
new file mode 100644
index 000000000000..ad3b416777be
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs"
+
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ >=sys-libs/readline-6.1
+ >=sys-libs/ncurses-5.7-r7
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ $(use_enable static-libs static) \
+ $(use_enable !minimal drivers) \
+ $(use_enable !minimal driverc)
+}
+
+src_install() {
+ default
+
+ use prefix && dodoc README*
+ use odbcmanual && dohtml -a css,gif,html,sql,vsd -r doc/*
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}