summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hyper-h2/hyper-h2-3.2.0.ebuild')
-rw-r--r--dev-python/hyper-h2/hyper-h2-3.2.0.ebuild29
1 files changed, 22 insertions, 7 deletions
diff --git a/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild b/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
index 50176089cdd7..819953993d97 100644
--- a/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
+++ b/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -13,8 +13,6 @@ SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/hyperframe-5.2.0[${PYTHON_USEDEP}]
@@ -22,14 +20,31 @@ RDEPEND="
>=dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
<dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
+
+PATCHES=(
+ # From https://github.com/python-hyper/h2/pull/1248
+ # Disables some failing healthchecks
+ "${FILESDIR}/${P}-failed-healthcheck.patch"
+)
+
python_test() {
- pytest -vv --hypothesis-profile=travis test ||
- die "Tests fail with ${EPYTHON}"
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # these rely on fixed string repr() and fail because enum repr
+ # changed in py3.10
+ test/test_basic_logic.py::TestBasicServer::test_stream_repr
+ test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
+ test/test_events.py::TestEventReprs::test_streamreset_repr
+ test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
+ test/test_events.py::TestEventReprs::test_connectionterminated_repr
+ )
+
+ epytest --hypothesis-profile=travis ${deselect[@]/#/--deselect }
}