summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-04 08:55:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2017-10-04 08:55:23 +0000
commitbdda87bde37f4d4c5bf513c1823831111f31a4e4 (patch)
tree75d1841a4244b932306b16d02efe95bb56225877
parentAdd initial 4.12 and 4.13 patch sets; same as 4.11 patch set (diff)
downloadgentoo-bdda87bde37f4d4c5bf513c1823831111f31a4e4.tar.gz
gentoo-bdda87bde37f4d4c5bf513c1823831111f31a4e4.tar.bz2
gentoo-bdda87bde37f4d4c5bf513c1823831111f31a4e4.zip
add ocaml 4.06 patches
-rw-r--r--src/patchsets/ocaml/4.06.0/020_all_configure.patch24
-rw-r--r--src/patchsets/ocaml/4.06.0/050_all_objinfoldflags.patch13
-rw-r--r--src/patchsets/ocaml/4.06.0/series2
3 files changed, 39 insertions, 0 deletions
diff --git a/src/patchsets/ocaml/4.06.0/020_all_configure.patch b/src/patchsets/ocaml/4.06.0/020_all_configure.patch
new file mode 100644
index 0000000000..ffd28518ce
--- /dev/null
+++ b/src/patchsets/ocaml/4.06.0/020_all_configure.patch
@@ -0,0 +1,24 @@
+Index: ocaml-4.06.0-beta1/configure
+===================================================================
+--- ocaml-4.06.0-beta1.orig/configure
++++ ocaml-4.06.0-beta1/configure
+@@ -577,6 +577,10 @@ case "$cc,$target" in
+ echo "#endif" >> m.h;;
+ esac
+
++# Append user flags
++common_cflags="$common_cflags ${CFLAGS}"
++ldflags="$ldflags ${LDFLAGS}"
++
+ # Configure compiler options to use in further tests.
+
+ export cclibs ldflags
+@@ -868,7 +872,7 @@ if $with_sharedlibs; then
+ *-*-linux*|*-*-freebsd[3-9]*|*-*-freebsd[1-9][0-9]*\
+ |*-*-openbsd*|*-*-netbsd*|*-*-dragonfly*|*-*-gnu*|*-*-haiku*)
+ sharedcccompopts="-fPIC"
+- mksharedlib="$cc -shared"
++ mksharedlib="$cc ${LDFLAGS} -shared"
+ ldflags="$ldflags -Wl,-E"
+ rpath="-Wl,-rpath,"
+ mksharedlibrpath="-Wl,-rpath,"
diff --git a/src/patchsets/ocaml/4.06.0/050_all_objinfoldflags.patch b/src/patchsets/ocaml/4.06.0/050_all_objinfoldflags.patch
new file mode 100644
index 0000000000..a9741462b2
--- /dev/null
+++ b/src/patchsets/ocaml/4.06.0/050_all_objinfoldflags.patch
@@ -0,0 +1,13 @@
+Index: ocaml-4.06.0-beta1/tools/Makefile
+===================================================================
+--- ocaml-4.06.0-beta1.orig/tools/Makefile
++++ ocaml-4.06.0-beta1/tools/Makefile
+@@ -314,7 +314,7 @@ DEF_SYMBOL_PREFIX = '-Dsymbol_prefix=""'
+ endif
+
+ objinfo_helper$(EXE): objinfo_helper.c ../byterun/caml/s.h
+- $(CC) $(CFLAGS) $(CPPFLAGS) -I../byterun $(OUTPUTEXE)$@ \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -I../byterun $(OUTPUTEXE)$@ \
+ $(DEF_SYMBOL_PREFIX) $(LIBBFD_INCLUDE) $< $(LIBBFD_LINK)
+
+ OBJINFO=../compilerlibs/ocamlcommon.cma \
diff --git a/src/patchsets/ocaml/4.06.0/series b/src/patchsets/ocaml/4.06.0/series
new file mode 100644
index 0000000000..afb5af891c
--- /dev/null
+++ b/src/patchsets/ocaml/4.06.0/series
@@ -0,0 +1,2 @@
+020_all_configure.patch
+050_all_objinfoldflags.patch