summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-17 08:05:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-17 08:05:17 +0000
commit216f4e9e189526e11ddc9d0769ab55f5816be7f8 (patch)
tree718a9881729a82faddc4ee79e5891bae5503ec32
parentVersion bump with gnome-3.6 visual fixes. Use a single flag for gtk2 and gtk3... (diff)
downloadgentoo-2-216f4e9e189526e11ddc9d0769ab55f5816be7f8.tar.gz
gentoo-2-216f4e9e189526e11ddc9d0769ab55f5816be7f8.tar.bz2
gentoo-2-216f4e9e189526e11ddc9d0769ab55f5816be7f8.zip
Fix build with gcc-4.7 Bug #422555
(Portage version: 2.1.11.28/cvs/Linux i686, signed Manifest commit with key 0145142D)
-rw-r--r--games-puzzle/xye/ChangeLog7
-rw-r--r--games-puzzle/xye/files/xye-0.12.0-gcc47.patch22
-rw-r--r--games-puzzle/xye/xye-0.12.0.ebuild9
3 files changed, 33 insertions, 5 deletions
diff --git a/games-puzzle/xye/ChangeLog b/games-puzzle/xye/ChangeLog
index 56cf5fe52d82..82aee808deef 100644
--- a/games-puzzle/xye/ChangeLog
+++ b/games-puzzle/xye/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/xye
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/ChangeLog,v 1.30 2012/07/02 20:55:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/ChangeLog,v 1.31 2012/10/17 08:05:17 tupone Exp $
+
+ 17 Oct 2012; Tupone Alfredo <tupone@gentoo.org> xye-0.12.0.ebuild,
+ +files/xye-0.12.0-gcc47.patch:
+ Fix build with gcc-4.7 Bug #422555 by Diego
+ Moving to EAPI 4
02 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> -xye-0.10.0.ebuild:
old
diff --git a/games-puzzle/xye/files/xye-0.12.0-gcc47.patch b/games-puzzle/xye/files/xye-0.12.0-gcc47.patch
new file mode 100644
index 000000000000..f638968dd404
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.0-gcc47.patch
@@ -0,0 +1,22 @@
+--- src/editorsave.cpp.old 2012-10-17 09:47:46.413566575 +0200
++++ src/editorsave.cpp 2012-10-17 09:48:17.314366174 +0200
+@@ -642,7 +642,8 @@
+ file << "<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>\n";
+ file << "<pack>\n<name>"<< stripXML(editorboard::filetitle) <<"</name><author>"<< stripXML(editorboard::author) <<"</author>\n<description>"<< stripXML(editorboard::description) <<"</description>\n";
+
+- for (int i=first; i<editorboard::CountLevels(); i++) {
++ int i;
++ for (i=first; i<editorboard::CountLevels(); i++) {
+ editorboard::LoadLevelNumber(board, i);
+ file << "\n<level>\n";
+ file << "<title>"<< stripXML(board->title) <<"</title>\n";
+--- src/gen.cpp.old 2012-10-17 09:41:40.825540267 +0200
++++ src/gen.cpp 2012-10-17 09:41:57.087387319 +0200
+@@ -21,6 +21,7 @@
+ #include<cstdio>
+ #include<iostream>
+ #include<fstream>
++#include <unistd.h>
+
+ const float F_RAND_MAX = (float)(RAND_MAX);
+
diff --git a/games-puzzle/xye/xye-0.12.0.ebuild b/games-puzzle/xye/xye-0.12.0.ebuild
index 843f8f4fcd79..63d22777aea3 100644
--- a/games-puzzle/xye/xye-0.12.0.ebuild
+++ b/games-puzzle/xye/xye-0.12.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/xye-0.12.0.ebuild,v 1.3 2012/01/21 16:33:05 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/xye-0.12.0.ebuild,v 1.4 2012/10/17 08:05:17 tupone Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils games
DESCRIPTION="Free version of the classic game Kye"
@@ -20,14 +20,15 @@ DEPEND="media-libs/libsdl[video]
media-fonts/dejavu"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
sed -i -e '/^xye_LDFLAGS/d' Makefile.am || die
eautoreconf
}
src_install() {
- dogamesbin "${PN}" || die
+ dogamesbin "${PN}"
insinto "${GAMES_DATADIR}/${PN}"
- doins -r levels res || die
+ doins -r levels res
rm -f "${D}${GAMES_DATADIR}/${PN}"/res/DejaVuSans*
dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/${PN}"/res/
dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}/${PN}"/res/