summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-26 04:40:39 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-26 04:40:39 +0000
commit3b98d1ae5b664dcc11ef10094a07c3bb68f77403 (patch)
treee6954d916ae27eee119dd1cd7a2fbd6255e7f29b
parentadd keyword list to recent entry in ChangeLog (diff)
downloadgentoo-2-3b98d1ae5b664dcc11ef10094a07c3bb68f77403.tar.gz
gentoo-2-3b98d1ae5b664dcc11ef10094a07c3bb68f77403.tar.bz2
gentoo-2-3b98d1ae5b664dcc11ef10094a07c3bb68f77403.zip
Version bump #544256 by Trinine.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--x11-wm/enlightenment/ChangeLog7
-rw-r--r--x11-wm/enlightenment/enlightenment-1.0.16.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index 4e3ff3086f34..a1aa7061681f 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.203 2015/03/17 02:20:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.204 2015/03/26 04:40:39 vapier Exp $
+
+*enlightenment-1.0.16 (26 Mar 2015)
+
+ 26 Mar 2015; Mike Frysinger <vapier@gentoo.org> +enlightenment-1.0.16.ebuild:
+ Version bump #544256 by Trinine.
*enlightenment-0.17.9999 (17 Mar 2015)
*enlightenment-0.19.4 (17 Mar 2015)
diff --git a/x11-wm/enlightenment/enlightenment-1.0.16.ebuild b/x11-wm/enlightenment/enlightenment-1.0.16.ebuild
new file mode 100644
index 000000000000..ecb4bbffad2f
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-1.0.16.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-1.0.16.ebuild,v 1.1 2015/03/26 04:40:39 vapier Exp $
+
+EAPI="4"
+if [[ ${PV} == *9999 ]] ; then
+ ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/E16/e"
+ inherit subversion autotools
+ SRC_URI=""
+ #KEYWORDS=""
+ S=${WORKDIR}/e16/e
+else
+ SRC_URI="mirror://sourceforge/enlightenment/e16-${PV/_/-}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+ S=${WORKDIR}/e16-${PV/_pre?}
+fi
+inherit eutils
+
+DESCRIPTION="Enlightenment Window Manager (e16)"
+HOMEPAGE="http://www.enlightenment.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="dbus doc nls pango pulseaudio xcomposite xinerama xrandr"
+
+RDEPEND="pulseaudio? ( media-sound/pulseaudio )
+ dbus? ( sys-apps/dbus )
+ pango? ( x11-libs/pango )
+ =media-libs/freetype-2*
+ >=media-libs/imlib2-1.3.0[X]
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXxf86vm
+ x11-libs/libXft
+ xrandr? ( x11-libs/libXrandr )
+ x11-libs/libXrender
+ x11-misc/xbitmaps
+ xinerama? ( x11-libs/libXinerama )
+ xcomposite? ( x11-libs/libXcomposite )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ xcomposite? ( x11-proto/compositeproto )
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( app-doc/edox-data )"
+
+src_prepare() {
+ if [[ ! -e configure ]] ; then
+ eautopoint
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable pulseaudio sound pulse) \
+ $(use_enable pango) \
+ $(use_enable xinerama) \
+ $(use_enable xrandr) \
+ $(use_enable xcomposite composite) \
+ --disable-docs \
+ --enable-zoom
+}
+
+src_install() {
+ default
+ dodoc COMPLIANCE sample-scripts/*
+ dohtml docs/e16.html
+}