summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2007-01-15 01:32:51 +0000
committerGustavo Felisberto <humpback@gentoo.org>2007-01-15 01:32:51 +0000
commit452c486f59dda924b79d2408b1db013201105559 (patch)
treebe7ded50976e278d427fea14a80178ecc01d6943
parentStable on amd64. Bug #160275. (diff)
downloadgentoo-2-452c486f59dda924b79d2408b1db013201105559.tar.gz
gentoo-2-452c486f59dda924b79d2408b1db013201105559.tar.bz2
gentoo-2-452c486f59dda924b79d2408b1db013201105559.zip
bump with extra patches :)
(Portage version: 2.1.1-r2)
-rw-r--r--app-backup/flexbackup/ChangeLog12
-rw-r--r--app-backup/flexbackup/files/digest-flexbackup-1.2.1-r33
-rw-r--r--app-backup/flexbackup/files/flexbackup-1.2.1-bash.patch18
-rw-r--r--app-backup/flexbackup/files/flexbackup-1.2.1-lzma.patch114
-rw-r--r--app-backup/flexbackup/flexbackup-1.2.1-r3.ebuild52
5 files changed, 197 insertions, 2 deletions
diff --git a/app-backup/flexbackup/ChangeLog b/app-backup/flexbackup/ChangeLog
index e4259fc693d0..26aae35e227f 100644
--- a/app-backup/flexbackup/ChangeLog
+++ b/app-backup/flexbackup/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-backup/flexbackup
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.8 2006/10/15 08:54:52 dertobi123 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.9 2007/01/15 01:32:51 humpback Exp $
+
+*flexbackup-1.2.1-r3 (15 Jan 2007)
+
+ 15 Jan 2007; Gustavo Felisberto <humpback@gentoo.org>;
+ +files/flexbackup-1.2.1-bash.patch, +files/flexbackup-1.2.1-lzma.patch,
+ +flexbackup-1.2.1-r3.ebuild:
+ Added new revision that fixes upsteam bugs #1611851 and #1222376 about lzma
+ compression and bash 3 detection.
15 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
flexbackup-1.2.1-r2.ebuild:
diff --git a/app-backup/flexbackup/files/digest-flexbackup-1.2.1-r3 b/app-backup/flexbackup/files/digest-flexbackup-1.2.1-r3
new file mode 100644
index 000000000000..92deefe369f4
--- /dev/null
+++ b/app-backup/flexbackup/files/digest-flexbackup-1.2.1-r3
@@ -0,0 +1,3 @@
+MD5 4955c89dbee354248f354a9bf0a480dd flexbackup-1.2.1.tar.gz 80158
+RMD160 d2a56ce6a3770498ef96ffbf75f65026b04f492c flexbackup-1.2.1.tar.gz 80158
+SHA256 58282b21985be75f1219c5ff4906d217055ed8627ea3e2ffdfe7a2393bc9d2c3 flexbackup-1.2.1.tar.gz 80158
diff --git a/app-backup/flexbackup/files/flexbackup-1.2.1-bash.patch b/app-backup/flexbackup/files/flexbackup-1.2.1-bash.patch
new file mode 100644
index 000000000000..a9da86a8e135
--- /dev/null
+++ b/app-backup/flexbackup/files/flexbackup-1.2.1-bash.patch
@@ -0,0 +1,18 @@
+--- flexbackup 2005-06-16 20:28:04.577086588 -0700
++++ flexbackup 2005-06-16 22:21:14.787322560 -0700
+@@ -5396,10 +5396,10 @@
+ my $shell = $1;
+ my $ver = $2;
+ if ($shell eq 'bash') {
+- if ($ver =~ m/^2/) {
+- $::shelltype{$host} = 'bash2';
+- } else {
++ if ($ver =~ m/^1/) {
+ $::shelltype{$host} = 'bash1';
++ } else {
++ $::shelltype{$host} = 'bash2';
+ }
+ } else {
+ $::shelltype{$host} = $shell;
+
+
diff --git a/app-backup/flexbackup/files/flexbackup-1.2.1-lzma.patch b/app-backup/flexbackup/files/flexbackup-1.2.1-lzma.patch
new file mode 100644
index 000000000000..ea61ba18df98
--- /dev/null
+++ b/app-backup/flexbackup/files/flexbackup-1.2.1-lzma.patch
@@ -0,0 +1,114 @@
+--- flexbackup 2003-10-10 15:12:09.000000000 +0100
++++ /home/humpback/Desktop/flexbackup 2007-01-15 01:08:18.000000000 +0000
+@@ -687,6 +687,8 @@
+ $filename .= ".zip";
+ } elsif ($cfg::compress eq "compress") {
+ $filename .= ".Z";
++ } elsif ($cfg::compress eq "lzma") {
++ $filename .= ".lzma";
+ }
+ } elsif ($cfg::type eq "afio") {
+ # tag these a little different, the archive file itself isn't a
+@@ -701,6 +703,8 @@
+ $filename .= "-zip";
+ } elsif ($cfg::compress eq "compress") {
+ $filename .= "-Z";
++ } elsif ($cfg::compress eq "lzma") {
++ $filename .= "-lzma";
+ }
+ }
+
+@@ -2700,7 +2704,7 @@
+ # First check if things are defined in the config file
+ # Checks exist, true/false, or one of options
+ &checkvar(\$cfg::type,'type','dump afio cpio tar star pax zip ar shar lha copy rsync filelist','tar');
+- &checkvar(\$cfg::compress,'compress','gzip bzip2 lzop compress zip false hardware','gzip');
++ &checkvar(\$cfg::compress,'compress','gzip bzip2 lzop compress zip false hardware lzma','gzip');
+ &checkvar(\$cfg::compr_level,'compr_level','exist','4');
+ &checkvar(\$cfg::verbose,'verbose','bool','true');
+ &checkvar(\$cfg::sparse,'sparse','bool','true');
+@@ -3001,6 +3005,16 @@
+ $::z = " | $::path{zip} -$cfg::compr_level - -";
+ $::unz = "$::path{funzip} | ";
+ }
++ } elsif ($cfg::compress eq "lzma") {
++ $::path{'lzma'} = &checkinpath($cfg::compress);
++ push(@::remoteprogs, $::path{$cfg::compress});
++ if ($cfg::compr_level !~ m/^[123456789]$/) {
++ push(@::errors,"\$compr_level must be set to 1-9");
++ } else {
++ $::z = " | $::path{$cfg::compress} -$cfg::compr_level ";
++ }
++ $::unz = "$::path{$cfg::compress} -d | ";
++
+ } else {
+ $::z = "";
+ $::unz = "";
+@@ -3252,6 +3266,10 @@
+ $::afio_z_flag = "-P $::path{$cfg::compress} -Q -c -Z";
+ $::afio_unz_flag = "-P $::path{$cfg::compress} -Q -d -Q -c -Z";
+
++ } elsif ($cfg::compress eq "lzma") {
++ $::afio_z_flag = "-P $::path{$cfg::compress} -Q -$cfg::compr_level -Z";
++ $::afio_unz_flag = "-P $::path{$cfg::compress} -Q -d -Z";
++
+ }
+ $::unz = ""; # Reset & just use this for reading the archive file.
+
+@@ -3415,7 +3433,7 @@
+ $::path{'lha'} = &checkinpath('lha');
+ push(@::remoteprogs, $::path{'lha'});
+
+- if ($cfg::compress =~ /^(gzip|bzip2|lzop|compress|zip)$/) {
++ if ($cfg::compress =~ /^(gzip|bzip2|lzop|compress|zip|lzma)$/) {
+ warn("Using type \"lha\" with compress=$cfg::compress makes no sense");
+ warn("Setting compression to false");
+ $::unz = "";
+@@ -3781,7 +3799,7 @@
+
+ # Try and guess file types and commpression scheme
+ # might as well since we are reading from a file in this case
+- if ($file =~ m/\.(dump|cpio|tar|star|pax|a|shar|filelist)\.(gz|bz2|lzo|Z|zip)$/) {
++ if ($file =~ m/\.(dump|cpio|tar|star|pax|a|shar|filelist)\.(gz|bz2|lzo|Z|zip|lzma)$/) {
+ $cfg::type = $1;
+ $cfg::compress = $2;
+ $cfg::type =~ s/^a$/ar/;
+@@ -3789,16 +3807,18 @@
+ $cfg::compress =~ s/bz2/bzip2/;
+ $cfg::compress =~ s/lzo/lzop/;
+ $cfg::compress =~ s/Z/compress/;
++ $cfg::compress =~ s/lzma/lzma/;
+ &log("| Auto-set to type=$cfg::type compress=$cfg::compress");
+ &optioncheck(); # redo to set a few variables over
+
+- } elsif ($file =~ m/\.afio-(gz|bz2|lzo|Z|zip)$/) {
++ } elsif ($file =~ m/\.afio-(gz|bz2|lzo|Z|zip|lzma)$/) {
+ $cfg::type = "afio";
+ $cfg::compress = $1;
+ $cfg::compress =~ s/gz/gzip/;
+ $cfg::compress =~ s/bz2/bzip2/;
+ $cfg::compress =~ s/lzo/lzop/;
+ $cfg::compress =~ s/Z/compress/;
++ $cfg::compress =~ s/lzma/lzma/;
+ &log("| Auto-set to type=$cfg::type compress=$cfg::compress");
+ &optioncheck(); # redo to set a few variables over
+
+@@ -5686,3 +5706,5 @@
+
+ return($spinner[$index]);
+ }
++
++
+--- flexbackup.conf 2007-01-15 01:11:36.000000000 +0000
++++ flexbackup.conf.new 2007-01-15 01:21:46.000000000 +0000
+@@ -33,8 +33,8 @@
+ $prune{'/'} = "tmp proc";
+
+ # Compression
+-$compress = 'gzip'; # one of false/gzip/bzip2/lzop/zip/compress/hardware
+-$compr_level = '4'; # compression level (1-9) (for gzip/bzip2/lzop/zip)
++$compress = 'gzip'; # one of false/gzip/bzip2/lzop/zip/compress/hardware/lzma
++$compr_level = '4'; # compression level (1-9) (for gzip/bzip2/lzop/zip/lzma)
+
+ # Buffering program - to help streaming
+ $buffer = 'false'; # one of false/buffer/mbuffer
diff --git a/app-backup/flexbackup/flexbackup-1.2.1-r3.ebuild b/app-backup/flexbackup/flexbackup-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..1725e5222c88
--- /dev/null
+++ b/app-backup/flexbackup/flexbackup-1.2.1-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/flexbackup-1.2.1-r3.ebuild,v 1.1 2007/01/15 01:32:51 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Flexible backup script using perl"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-apps/findutils
+ app-arch/tar
+ app-arch/mt-st"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/flexbackup-1.2.1-lzma.patch
+ #Substituting out this patch for bug #116510
+# epatch "${FILESDIR}"/${P}-CAN-2005-2965.patch
+ epatch "${FILESDIR}"/flexbackup-1.2.1-secure-tempfile.patch
+ epatch ${FILESDIR}/flexbackup-1.2.1-bash.patch
+
+ sed -i \
+ -e '/^\$type = /s:afio:tar:' \
+ -e "/^\$buffer = /s:'buffer':'false':" \
+ flexbackup.conf || die
+}
+
+src_install() {
+ dodir /etc /usr/bin /usr/share/man/man{1,5}
+ make install \
+ PREFIX="${D}"/usr \
+ CONFFILE="${D}"/etc/flexbackup.conf \
+ || die
+
+ dodoc CHANGES CREDITS INSTALL README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ einfo "Please edit your /etc/flexbackup.conf file to suit your"
+ einfo "needs. If you are using devfs, the tape device should"
+ einfo "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ einfo "archiver other than tar, please emerge it separately."
+}