summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-08 05:36:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-08 05:36:07 +0000
commit6104a65e205373fa6af210e7feee8ec0902049c4 (patch)
treed0a408721cfed96954fd2225dda4d5a4a7a1ac1b
parentVersion bump. Now use cmake, rewritten from scratch and respect upstream options (diff)
downloadgentoo-2-6104a65e205373fa6af210e7feee8ec0902049c4.tar.gz
gentoo-2-6104a65e205373fa6af210e7feee8ec0902049c4.tar.bz2
gentoo-2-6104a65e205373fa6af210e7feee8ec0902049c4.zip
Keyword amd64-linux, x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
-rw-r--r--sci-physics/xfoil/ChangeLog9
-rw-r--r--sci-physics/xfoil/metadata.xml4
-rw-r--r--sci-physics/xfoil/xfoil-6.97.ebuild22
3 files changed, 19 insertions, 16 deletions
diff --git a/sci-physics/xfoil/ChangeLog b/sci-physics/xfoil/ChangeLog
index 7f89c4ba6a8c..097e40c95ee5 100644
--- a/sci-physics/xfoil/ChangeLog
+++ b/sci-physics/xfoil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/xfoil
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.16 2011/06/21 14:31:36 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.17 2012/08/08 05:36:07 bicatali Exp $
+
+ 08 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ xfoil-6.97.ebuild:
+ Keyword amd64-linux, x86-linux
21 Jun 2011; Justin Lecher <jlec@gentoo.org> xfoil-6.97.ebuild:
Add dependency on virtual/fortran
@@ -92,4 +96,3 @@
03 Dec 2003; Robin H. Johnson <robbat2@gentoo.org> xfoil-6.94.ebuild:
initial ebuild by robbat2@gentoo.org
-
diff --git a/sci-physics/xfoil/metadata.xml b/sci-physics/xfoil/metadata.xml
index c2e54a0de070..7a6116831268 100644
--- a/sci-physics/xfoil/metadata.xml
+++ b/sci-physics/xfoil/metadata.xml
@@ -6,8 +6,8 @@
<email>robbat2@gentoo.org</email>
</maintainer>
<longdescription lang="en">
-XFOIL is an interactive program for the design and analysis of subsonic isolated airfoils.
-It consists of a collection of menu-driven routines which perform various useful functions such as:
+ XFOIL is an interactive program for the design and analysis of subsonic isolated airfoils.
+ It consists of a collection of menu-driven routines which perform various useful functions such as:
* Viscous (or inviscid) analysis of an existing airfoil
* Airfoil design and redesign by interactive modification of surface speed distributions
* Airfoil redesign by interactive modification of geometric parameters
diff --git a/sci-physics/xfoil/xfoil-6.97.ebuild b/sci-physics/xfoil/xfoil-6.97.ebuild
index 5bf398c51d49..4f250a3939a7 100644
--- a/sci-physics/xfoil/xfoil-6.97.ebuild
+++ b/sci-physics/xfoil/xfoil-6.97.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.8 2011/06/21 14:31:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.9 2012/08/08 05:36:07 bicatali Exp $
-EAPI=3
+EAPI=4
inherit eutils fortran-2
DESCRIPTION="Design and analysis of subsonic isolated airfoils"
@@ -12,7 +12,7 @@ SRC_URI="http://web.mit.edu/drela/Public/web/${PN}/${PN}${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
RDEPEND="
@@ -44,27 +44,27 @@ src_prepare() {
src_compile() {
export FC="$(tc-getFC)" F77="$(tc-getF77)"
cd "${S}"/orrs/bin
- emake FLG="${FFLAGS}" FTNLIB="${LDFLAGS}" OS || die "failed to build orrs"
+ emake FLG="${FFLAGS}" FTNLIB="${LDFLAGS}" OS
cd "${S}"/orrs
bin/osgen osmaps_ns.lst
cd "${S}"/plotlib
- emake CFLAGS="${CFLAGS} -DUNDERSCORE" || die "failed to build plotlib"
+ emake CFLAGS="${CFLAGS} -DUNDERSCORE"
cd "${S}"/bin
for i in xfoil pplot pxplot; do
emake \
PLTOBJ="../plotlib/libPlt.a" \
CFLAGS="${CFLAGS} -DUNDERSCORE" \
FTNLIB="${LDFLAGS}" \
- ${i} || die "failed to build ${i}"
+ ${i}
done
}
src_install() {
- dobin bin/pplot bin/pxplot bin/xfoil || die "dobin failed"
+ dobin bin/pplot bin/pxplot bin/xfoil
insinto /usr/share/xfoil/orrs
- doins orrs/osm*.dat || die "orrs data install failed"
- dodoc *.txt README || die "dodoc failed"
+ doins orrs/osm*.dat
+ dodoc *.txt README
insinto /usr/share/doc/${PF}/
- use examples && { doins -r runs || die "examples install failed"; }
+ use examples && doins -r runs
use doc && dodoc "${DISTDIR}"/dataflow.pdf
}