summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-26 05:18:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-26 05:18:03 +0000
commit662842662387fe9e4e95cefc16c3460d521be4d9 (patch)
tree15099da52894a9f52a5d8f1f0659020e7a71f37a
parenttypo fixed - s/mconf/myconf/ (diff)
downloadgentoo-2-662842662387fe9e4e95cefc16c3460d521be4d9.tar.gz
gentoo-2-662842662387fe9e4e95cefc16c3460d521be4d9.tar.bz2
gentoo-2-662842662387fe9e4e95cefc16c3460d521be4d9.zip
new version
-rw-r--r--net-mail/postfix/files/digest-postfix-1.1.21
-rw-r--r--net-mail/postfix/postfix-1.1.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/net-mail/postfix/files/digest-postfix-1.1.2 b/net-mail/postfix/files/digest-postfix-1.1.2
new file mode 100644
index 000000000000..1c5ac81a8698
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-1.1.2
@@ -0,0 +1 @@
+MD5 685c27bc353a0625c3e3129baa613183 postfix-1.1.2.tar.gz 1179648
diff --git a/net-mail/postfix/postfix-1.1.2.ebuild b/net-mail/postfix/postfix-1.1.2.ebuild
new file mode 100644
index 000000000000..41cfd9e031f2
--- /dev/null
+++ b/net-mail/postfix/postfix-1.1.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Jerry Alexandratos <jerry@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-1.1.2.ebuild,v 1.1 2002/01/26 05:18:03 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/official/${P}.tar.gz"
+HOMEPAGE="http://www.postfix.org/"
+
+PROVIDE="virtual/mta"
+
+DEPEND="virtual/glibc
+ >=dev-libs/libpcre-3.4
+ >=sys-libs/db-3.2
+ mta-ldap? ( >=net-nds/openldap-1.2 )
+ mta-mysql? ( >=dev-db/mysql-3.23.28 )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00
+ !virtual/mta"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/conf
+ cp main.cf main.cf.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" main.cf.orig > main.cf
+
+ cd ${S}/src/global
+ cp mail_params.h mail_params.h.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" mail_params.h.orig > mail_params.h
+
+ use mta-ldap && ( CCARGS="${CCARGS} -DHAS_LDAP" ; AUXLIBS="${AUXLIBS} -lldap -llber" )
+ use mta-mysql && ( CCARGS="${CCARGS} -DHAS_MYSQL" ; AUXLIBS="${AUXLIBS} -lmysqlclient -lm" )
+
+ CCARGS="-I/usr/include -DHAS_PCRE" ; AUXLIBS="-L/usr/lib -lpcre"
+
+ cd ${S} ; make makefiles CC="cc ${CFLAGS} ${CCARGS} ${AUXLIBS}" || die
+}
+
+src_compile() {
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ dodir /usr/bin /usr/sbin /usr/lib/postfix /etc/postfix/sample
+ dodir /var/spool/postfix /var/spool/postfix/maildrop
+ fowners postfix.root /var/spool/postfix/maildrop
+ fperms 1733 /var/spool/postfix/maildrop
+
+ cd ${S}/bin ; dosbin post* sendmail
+ dosym /usr/sbin/sendmail /usr/bin/mail
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+ cd ${S}/libexec ; exeinto /usr/lib/postfix ; doexe *
+ cd ${S}/man ; doman man*/*
+
+ cd ${S}
+ dodoc *README COMPATIBILITY HISTORY LICENSE PORTING RELEASE_NOTES
+ docinto html ; dodoc html/*
+
+ cd ${S}/conf
+ insinto /etc/postfix/sample
+ doins access aliases canonical relocated transport
+ doins pcre_table regexp_table postfix-script* *.cf
+ exeinto /etc/postfix ; newexe postfix-script-sgid postfix-script
+ insinto /etc/postfix ; doins ${FILESDIR}/main.cf ${S}/conf/master.cf
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/postfix.rc6 postfix
+}
+
+pkg_postinst() {
+ echo
+ echo "***************************************************************"
+ echo "* NOTE: Please add the 'postdrop' group, and also be sure *"
+ echo "* to update /etc/postfix/master.cf to the latest *"
+ echo "* as postfix 1.1.2's is not compadible with earlier *"
+ echo "* versions. *"
+ echo "***************************************************************"
+ echo
+}