summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-08-08 12:12:15 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-08-08 12:12:15 +0000
commitaa1c5957e5d0d99969a88c1a976462fae45c1e8e (patch)
tree711e0330d2cc650397bf070541fe774f67d9b4b4
parentKeyworded on alpha, bug 539366 (diff)
downloadgentoo-2-aa1c5957e5d0d99969a88c1a976462fae45c1e8e.tar.gz
gentoo-2-aa1c5957e5d0d99969a88c1a976462fae45c1e8e.tar.bz2
gentoo-2-aa1c5957e5d0d99969a88c1a976462fae45c1e8e.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-libs/libinput/ChangeLog7
-rw-r--r--dev-libs/libinput/libinput-0.21.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-libs/libinput/ChangeLog b/dev-libs/libinput/ChangeLog
index cbf81e5a50b1..22693ab0fdd2 100644
--- a/dev-libs/libinput/ChangeLog
+++ b/dev-libs/libinput/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libinput
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.28 2015/07/25 11:55:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.29 2015/08/08 12:12:15 mrueg Exp $
+
+*libinput-0.21.0 (08 Aug 2015)
+
+ 08 Aug 2015; Manuel Rüger <mrueg@gentoo.org> +libinput-0.21.0.ebuild:
+ Version bump.
25 Jul 2015; Pacho Ramos <pacho@gentoo.org> libinput-0.9.0.ebuild:
ppc stable, bug #553500
diff --git a/dev-libs/libinput/libinput-0.21.0.ebuild b/dev-libs/libinput/libinput-0.21.0.ebuild
new file mode 100644
index 000000000000..6dfa38590428
--- /dev/null
+++ b/dev-libs/libinput/libinput-0.21.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/libinput-0.21.0.ebuild,v 1.1 2015/08/08 12:12:15 mrueg Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}