summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-04-24 11:43:21 +0000
committerIan Delaney <idella4@gentoo.org>2015-04-24 11:43:21 +0000
commitb81b79f28bafab28189b0fe8534aad1c9e83c045 (patch)
tree15b889c7391e44df6c01df6827b3f594ae82d3d3
parentVersion bump (diff)
downloadgentoo-2-b81b79f28bafab28189b0fe8534aad1c9e83c045.tar.gz
gentoo-2-b81b79f28bafab28189b0fe8534aad1c9e83c045.tar.bz2
gentoo-2-b81b79f28bafab28189b0fe8534aad1c9e83c045.zip
bump; add doc build, update test phase
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/yapsy/ChangeLog7
-rw-r--r--dev-python/yapsy/yapsy-1.11.023.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/yapsy/ChangeLog b/dev-python/yapsy/ChangeLog
index f2caafbc1397..e1df831609c7 100644
--- a/dev-python/yapsy/ChangeLog
+++ b/dev-python/yapsy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/yapsy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yapsy/ChangeLog,v 1.16 2015/01/16 04:54:05 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yapsy/ChangeLog,v 1.17 2015/04/24 11:43:21 idella4 Exp $
+
+*yapsy-1.11.023 (24 Apr 2015)
+
+ 24 Apr 2015; Ian Delaney <idella4@gentoo.org> +yapsy-1.11.023.ebuild:
+ bump; add doc build, update test phase
16 Jan 2015; Ian Delaney <idella4@gentoo.org> -yapsy-1.10.1.ebuild,
-yapsy-1.10.2.ebuild, yapsy-1.10.423.ebuild:
diff --git a/dev-python/yapsy/yapsy-1.11.023.ebuild b/dev-python/yapsy/yapsy-1.11.023.ebuild
new file mode 100644
index 000000000000..a9abf3ed0648
--- /dev/null
+++ b/dev-python/yapsy/yapsy-1.11.023.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yapsy/yapsy-1.11.023.ebuild,v 1.1 2015/04/24 11:43:21 idella4 Exp $
+
+EAPI="5"
+
+MY_P="Yapsy-${PV}"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fat-free DIY Python plugin management toolkit"
+HOMEPAGE="http://yapsy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable erroneous test
+ sed -e 's:test_default_plugins_place_is_parent_dir:_&:' \
+ -i test/test_PluginFileLocator.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}