summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-04 14:04:33 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-04 14:04:33 +0000
commitc597b392f6c58921ee44182c7cc00587d421cf77 (patch)
tree681ad19d8be68d50ad14585055589c939f9c23f3
parentMigrate to python-r1 (requested in bug #455378). (diff)
downloadgentoo-2-c597b392f6c58921ee44182c7cc00587d421cf77.tar.gz
gentoo-2-c597b392f6c58921ee44182c7cc00587d421cf77.tar.bz2
gentoo-2-c597b392f6c58921ee44182c7cc00587d421cf77.zip
Migrate to distutils-r1 (requested in bug #455336).
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
-rw-r--r--dev-tex/dot2tex/ChangeLog9
-rw-r--r--dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-tex/dot2tex/ChangeLog b/dev-tex/dot2tex/ChangeLog
index 9a29a6591ffe..61f9a00220d3 100644
--- a/dev-tex/dot2tex/ChangeLog
+++ b/dev-tex/dot2tex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/dot2tex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/ChangeLog,v 1.30 2012/12/31 13:05:31 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/ChangeLog,v 1.31 2013/02/04 14:04:33 mgorny Exp $
+
+*dot2tex-2.8.7-r1 (04 Feb 2013)
+
+ 04 Feb 2013; Michał Górny <mgorny@gentoo.org> +dot2tex-2.8.7-r1.ebuild:
+ Migrate to distutils-r1 (requested in bug #455336).
31 Dec 2012; Michał Górny <mgorny@gentoo.org> dot2tex-2.8.7.ebuild:
Use virtual/pyparsing.
diff --git a/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild b/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild
new file mode 100644
index 000000000000..3648aa74ceea
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild,v 1.1 2013/02/04 14:04:33 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="http://www.fauskes.net/code/dot2tex/"
+SRC_URI="http://dot2tex.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND="virtual/pyparsing[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r doc/*
+ dodoc doc/usage.{txt,pdf}
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}